AHCI Boot issues

I'm trying to understand how the AHCI/TRIM SSD issues all work out and It's still a little confusing.

I decided to reformat my boot drive, and try to set up my PC properly so that TRIM works on my SSDs. I set my motherboard settings to AHCI, then ran the windows 7 install disc where I formatted my boot drive and re-installed Windows 7 on it.

I have a Gigabyte Z68XP-UD3P motherboard purchased in April of this year. I didn't look for a B3 because I figured that was all worked out last year, and I didn't need to look for those specific ones. Hopefully that's not my problem. It's got the wonderful "Touch BIOS Hybrid EFI" that I can't figure out what exactly I would be changing.

Since doing that, my boot order can't be changed (the order my mobo checks the hard drives) and my boot drive is 3rd on the list.

When I go in to check my drives, they don't show up.
IDE - Channel 0 Master (none)
Channel 0 Slave (none)
Channel 1 Master (none)
Channel 1 Slave (none)
Channel 2 Master (none)
Channel 3 Master (none)
Channel 4 Master (shows my 1TB Raptor)
Channel 4 Slave (shows my 600GB Raptor)

Prior to this, it would show my DVD drives, and SSds in the other slots (channel's 0-3).

My "Hard Disk Boot Priority" is out of order, and it takes between 1-2 minutes to start up (haven't timed it exactly), but that's a long time since my boot drive is an SSD.
1. 1TB Raptor
2. 600GB Raptor
3. 128GB SSD (BOOT drive)
4. other SSD
5. other SSD)

Some of the settings I'm curious about:
Sata port 0-3 Native Mode - ENABLED
(enabled = native IDE mode, disabled = legacy ide mode)

GSATA3 Controller - ENABLED
GSATA3 Ctrl Mode - AHCI
(IDE = GSATA ports IDE, AHCI = GSATA ports AHCI, Raid = GSATA and IDE Raid Mode)

I am looking for help to change some settings so that I can change my boot order and speed up my boot time, and also ensure that TRIM is working. Samsung SSD Magician does say that I'm in AHCI mode, so that makes me feel like I'm not completely retarded.

However when trying to optimize the drive (and I'll contact Samsung for this), I got error 1060 and it couldn't optimize the drive.

Thanks in advance for any help!
5 answers Last reply Best Answer
More about ahci boot issues
  1. Best answer
    Is the SSD on a GSATA port?

    If so, change it to one of the Intel 6Gbps SATA ports. The GSATA are on the Marvell controller and do not do well with the OS SSD on them. If you have the Marvell controller on, which I would only do if you absolutely need those two ports, your boot time will be slower.
  2. I'll have to double check.

    How would I turn the Marvel controller off, or should I put my HDD's on them?
  3. If you have enough Intel ports, there are 6 -- two 6Gbps and four 3 Gbps, use them and forget the Marvel ports. You would turn it off in the bios -- look under the Integrated Peripherals tab and disable the GSATA 3 controller.
  4. Best answer selected by kaveman44.
  5. Thanks for your help beast! I've been super busy with work, but I wanted to say thank you for being able to help.
Ask a new question

Read More

SSD Boot Storage