Sign in with
Sign up | Sign in
Your question

Kingston Hyperx firmware update failure

Last response: in Storage
Share
July 6, 2012 3:10:27 PM

Hi there. I bought a Kingston HYPERX 120GB SSD drive recently. All worked fine, until I tried to update its firmware. Once I pressed the button for the firmware update, my PC hung. I waited for some 15 minutes, but nothing changed. I tried pressing Ctrl+Alt+Delete but nothing. Not even the mouse pointer would work. So I pressed the restart button. Now the disk is unrecognizable in BIOS. I tried booting my old installation of Windows 7, and run the update program. It does not recognize any drive either. So, any ideas other than contacting Kingston? Thank you in advance
a b G Storage
July 6, 2012 7:12:10 PM

it sounds like you need to contact Kingston actually...
July 7, 2012 8:49:27 AM

Indeed it does, and I already did, but I hoped there was a workaround of some sort. I'm waiting for a response to the e-mail I sent to them. Anyway, thanks for the reply nhasian.
Related resources
a c 180 G Storage
July 7, 2012 11:53:03 AM

Never update SSD firmware unless you have an issue with it.I installed a Hyper X several weeks back and it's running fast and flawless.
August 26, 2012 6:59:50 PM

Today I tried to update the firmware of my Kingston Hyperx 120G with SH103_FW503.ffp using KINGSTON SSDNow SF Updater utility. Badly failed. I use Windows 7 Ultimate and my system crashed twice -got blue screen with a lots of instructions "..automatically shutdown to save Windows...". Fortunately the SSD is still intact and having read comments on this forum I have abandoned the idea of an upgrade. Thanks everyone.
a c 180 G Storage
August 27, 2012 3:44:21 AM

Never flash firmware unless needed.
!