Sign in with
Sign up | Sign in
Your question

Bios cannot detect marvell sata 6gb

Last response: in Motherboards
Share
February 10, 2011 7:37:06 AM

I just finished building my new rig. But after booting up 1st time into bios, my mother board cant seem to detect the HDDs connected to the marvell sata 3.0 6gb connectors. I have 3 HDD and 1 optical, and considering intel cougar point chipsets have a fault in the sata 2 3gb connectors I would avoid using them at any cost. I tried installing the driver for marvell after installing windows but it doesn't seem to work. The HDDs can be detected when plugged into the sata 2.0 3GB. To note another point, the installation of the drivers for marvell is also rather strange; onli a message box appears stating that it is installing drivers, and subsequently disappears after few seconds. In device manager, under storage controllers the marvell thing is there and enabled.

I've also checked the bios to make sure that the marvell controller is enabled.

Any idea what's wrong and what solutions are possible?

Intel i7-2600K
ASUS P8P67 WS Revo
GSkill 4gbx2 sandy bridge ddr3-2133mhz
evga gtx 580x2
antec high current pro 1200W
corsair obsidian h800
Creative sound blaster titanium hd
2x WD caviar black 1TB
1x WD caviar green 500GB
1x bluray dvd combo
a b V Motherboard
February 10, 2011 12:08:09 PM

Is the marvell chipset enabled in the BIOS?

You may need to install the marvell drivers with the F6 process during the Windows install.
a c 715 V Motherboard
February 10, 2011 12:52:15 PM

By default the Marvell controller is Enabled, have you look in the 'Ctrl + M' during BIOS booting to access the Marvell control panel? You can Load Defaults if you changed a setting that's interfering. The Marvell Ports don't show-up in the standard BIOS screens.

I am a little foggy with what you're trying to do?

Ia assume the following based upon what you're saying:

Intel SATA3_{Gray} = Primary OS HDD *
Intel SATA3_{Gray} = DVD/ODD
Marvell SATA3_{Navy} = HDD2
Marvell SATA3_{Navy} = HDD3
* I assume this configuration since you're installing an OS to otherwise invisible Marvell HDDs.
Related resources
February 12, 2011 7:10:51 AM

yes that's the right config.
a c 715 V Motherboard
February 12, 2011 2:21:24 PM

Are they working?
February 12, 2011 2:22:30 PM

now it is
February 12, 2011 3:02:25 PM

on a 2nd note, enabling the marvell sata controller causes immense latency to my audio and video streams. good thing they're gona replace my mobo soon
a c 715 V Motherboard
February 12, 2011 3:46:40 PM

Yep, I've seen this problem reported before but on Gigabyte MOBOs. There's a few causes and a few fixes.

Q - What Anti-Virus App?
Q - Is the Temp Folder location on the Primary?
Q - Are you using the onboard sound?

Q - If you disable the AV does it correct the problems?
Q - Have you downloaded ALL the latest Driver from ASUS?
February 12, 2011 4:01:52 PM

A - no anti virus installed yet
A - it should be, considering it's in the C drive
A - using creative xfi titanium HD, but when plug speakers into on board, also have the static sound

A - AV as in audio visual?
A - updated all drivers to latest before hand

the solution seems to be disabling the marvell sata 6g controller.
a c 715 V Motherboard
February 12, 2011 4:16:19 PM

AV also means Anti-Virus which is N/A. The problem probably is the combination of Creative + Marvell.

Oddly, yes in this case, 'my curiosity' -- if you [A] Disable the Creative in the Device Manager and use the onboard sound does that 'fix' the problem? You might also want to try disabling ALL sound but the Creative. In either case followed by a restart.

Try [A] or

If it does fix the lagging then keep it that way until you can Disable the Marvell and Enable the Creative/Onboard. Why drive yourself nuts for a month or probably two.
February 12, 2011 4:19:36 PM

nope disabling just creative or all onboard sound doesnt fix it. even tried all other things like usb controllers and LAN
a c 715 V Motherboard
February 12, 2011 4:30:17 PM

How about simply pulling the Creative card?

I've had problems with Creative sound cards before and have been using the HT | OMEGA.
February 12, 2011 4:33:32 PM

did so and still no avail. i've previously used that card on my previous rig and no problems
a c 715 V Motherboard
February 12, 2011 4:49:07 PM

Probably won't do a thing, but the latest driver was posted yesterday; Driver 3.00.1004 -> http://tinyurl.com/4ac6d56
February 12, 2011 4:52:48 PM

already updated that one.. thanks anyway
!