Sign in with
Sign up | Sign in
Your question

USB hub prevents system from powering-up?

Last response: in Systems
Share
May 22, 2010 1:03:04 PM

Hey guys, I just put together a home built system to replace my old desktop. Everything went pretty well until I tried to use a self-powered USB hub. After I plugged it in the USB port, it worked well, but after I turned the PC off, it won't power up unless I unplug the USB hub. Any ideas why this is happening? The USB hub I'm using looks like this:

http://www.ubergizmo.com/photos/2007/7/7-port-tiny-towe...

Here is the components I used:

MB: ASRock M3A785GXH/128M
CPU: AMD Athlon II X2 250 @ 3.45GHz
Mem: G.SKILL 4GB (2 x 2GB) PC3 12800
PSU: Antec 380W

Thanks a lot!
a c 122 B Homebuilt system
May 22, 2010 5:48:48 PM

A lot of inexpensive motherboards do that. It's not that unusual. As far as I know, there isn't anything that you can do except ensure that USB devices are unplugged when you boot.
m
0
l
December 6, 2013 10:47:55 AM

I had the identical problem with a hub which looks precisely the same as the one in your pic. Problem was maddening.
PC would power on and work fine, but when I connected the USB hub, would not switch on - no fans, no lights, nothing.
Drove me mad - in the lab PC would power on fine, but at my desk, nothing.
Took a completely different PC - same symptom.
Finally I narrowed it down to the USB hub - power from the hub must be feeding back to the PC. Removed the hub and PC works properly. I'm not sure if it's the hub or its dinky switched power supply.
Same symptom on a Gigabyte medium quality motherboard and a different system with a medium quality ASUS motherboard.
m
0
l
December 30, 2013 5:52:02 PM

I just realized the same thing with a new system. I have a ASUS X79 Sabertooth MB and it has diagnostic LEDs on the MB and I noticed the stand by LED was still on with the PSU plug disconnected. I then unplugged the USB cables and it went out immediately. When the computer won't power up I just unplug the hub and it fires up immediately. I am using some cheap hubs off Ebay so perhaps I will buy some better powered hubs now.
m
0
l
!