Sign in with
Sign up | Sign in
Your question

Cpu at 2.0 ghz should be 2.5

Last response: in CPUs
Share
July 27, 2010 4:16:02 PM

Recently I bought a new cpu, and motherboard.. When I boot up I read that it says: Intel quad core Q8300 @ 2.5 GHz - Speed : 2.0 GHZ. After doing tests and stuff, it says that its at 2.0 ghz.. Im pretty sure that it only uses its full 2.5 when under stress.. Is this some sort of power saving? And can I disable this?

And sorry if you have this question a lot, I couldn't really find the right words to describe/search it..

More about : cpu ghz

a c 203 à CPUs
a b V Motherboard
July 27, 2010 4:30:20 PM

That is Intel's power saving Speed-Step option. It's turned on in your BIOS settings.
You could turn it off - but it's not necessary to do that. Your CPU will 'speed up' when you start working it hard.
m
0
l
a c 203 à CPUs
a b V Motherboard
July 27, 2010 4:32:34 PM

A better explain here:
Why is my CPU not showing correct speeds?
That topic is now hidden up at the top in the sticky topic: [CPUs] CPU Buyer's Guides, Troubleshooting and Folding@Home
m
0
l
Related resources
July 27, 2010 4:37:27 PM

I don't have that option in bios. I have Asrock 4CoreDual sata R2.0 motherboard, which is a pretty dodgy mobo.. Is that the only way? Or is it hidden somewhere else..?
m
0
l
a c 203 à CPUs
a b V Motherboard
July 27, 2010 4:45:29 PM

Mostly likely to be in the Advanced - CPU section if your motherboard offers the option.
m
0
l
a c 203 à CPUs
a b V Motherboard
July 27, 2010 4:46:39 PM

Have you confirmed the CPU speeds up to 2.5Ghz during a game or benchmark test?
m
0
l
July 27, 2010 4:49:45 PM

No.. But I assume that since it says 2.5 Ghz, that it would be able to go that high.. And I looked in Advanced CPU options, and it was nowhere to be seen.. I'll run a benchmark..
m
0
l
July 27, 2010 4:56:37 PM

What benchmark should I use..?
m
0
l
a c 203 à CPUs
a b V Motherboard
July 27, 2010 4:57:35 PM

You can start up an anti-virus scan. That should be enough to kick the CPU up to full speed.
m
0
l
July 27, 2010 5:00:10 PM

i also have same Quad and asus P5KPL-AM/PS mobo, where is that option to disable that speed step? and yes i did notice my cpu goes to 2.5 when i minimize gta 4....
m
0
l
July 27, 2010 5:06:02 PM

hey i just right click on my comp and get the properties, there it shows like this,
intel(R) core(TM)2 Quad CPU Q8300 @2.50 Ghz 2.51 Ghz,
however CPU-Z shows 2.00 Ghz when not under load.......
m
0
l
July 27, 2010 5:06:06 PM

I just noticed, in bios it shows Intel Quad Core Q8300 (64bit) or something like that, does that mean i need a 64bit operating system..?
m
0
l
July 27, 2010 5:07:48 PM

rohn_avni said:
hey i just right click on my comp and get the properties, there it shows like this,
intel(R) core(TM)2 Quad CPU Q8300 @2.50 Ghz 2.51 Ghz,
however CPU-Z shows 2.00 Ghz when not under load.......


Mine says Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50 GHz 2.00 GHz, 2.00 GB of RAM
m
0
l
July 27, 2010 5:08:06 PM

Arigo said:
I just noticed, in bios it shows Intel Quad Core Q8300 (64bit) or something like that, does that mean i need a 64bit operating system..?

no u will not need a 64 bit os, it just means processor supports 64 bit computing and u can install 64 bit os, if u have more than 3.5 GB of ram then u will need 64 bit OS....so u can use more than 4 GB of ram..... :) 
m
0
l
a c 203 à CPUs
a b V Motherboard
July 27, 2010 5:09:26 PM

It means the CPU is 64bit capable, not that you need a 64bit OS.
m
0
l
July 27, 2010 5:14:54 PM

Arigo said:
Mine says Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50 GHz 2.00 GHz, 2.00 GB of RAM

ohh then it's a problem i think... cause ur procesor shows 2.0 Ghz mine shows 2.51...... i think check ur power profile or recheck ur bios and reset ur bios to default values.... :??: 
m
0
l
a c 203 à CPUs
a b V Motherboard
July 27, 2010 5:17:35 PM

If you still need a benchmark / stress test you can download 3DMark06 Basic Edition here.
m
0
l
July 27, 2010 5:21:22 PM

I tried running some wierd cpu stress test I found, it got my cpu usage to 90-100% usage, but still read 1995.6 (and changed around a bit) in CPU-Z
m
0
l
July 27, 2010 5:23:56 PM

Arigo said:
I tried running some wierd cpu stress test I found, it got my cpu usage to 90-100% usage, but still read 1995.6 (and changed around a bit) in CPU-Z

then it's ur mobo holding ur cpu back... there has to be a setting in bios check manual.. or just reset bios...
m
0
l
July 27, 2010 5:31:33 PM

its a brand new motherboard, with a fresh reformat.. I don't think it needs a reset, and there isn't any settings, besides like limit CPUID or something, which i tried enabling, and disabling (disabeld by default)
m
0
l
a c 203 à CPUs
a b V Motherboard
July 27, 2010 5:34:01 PM

I was worried about that when I saw that note about Speed Step being disabled.
I think you're stuck at 2.0Ghz (1995.6).
m
0
l
July 27, 2010 5:34:01 PM

Arigo said:
its a brand new motherboard, with a fresh reformat.. I don't think it needs a reset, and there isn't any settings, besides like limit CPUID or something, which i tried enabling, and disabling (disabeld by default)

reseting bios will not harm ur pc, don't worry it's a 1 sec process.... just use the default settings of bios. give it a try..
m
0
l
!