Sign in with
Sign up | Sign in
Your question

Possibly Malfunctioning ATI 5750. Need help

Last response: in Graphics & Displays
Share
April 21, 2010 9:37:10 AM

I hope im posting in the right section. Recently ive bought a new system for my sister. Its a fairly decent config.

Intel i5 650
Gigabyte GA-P55-UD3
1 TB WD SATA Hard Drive
2 x 2 GB DDR3 1600 Mhz G skill Ram
1 GB Gigabyte Radeon HD 5750
Lexa Blackline Case
Linksys Wifi PCI Adapter
Coolermaster GX 750 W PSU

Ever since the pc was built there have been stability issues. I installed Windows 7 Home edition 64 bit on the system. Starting from the 2nd day itself there were problems.

Very frequently windows would refuse to load past the 'Windows Starting screen' and would freeze there. Only a system restore and a couple of times a clean reinstall would get me past this.

Sometimes after a restart or a shutdown about 2gb+ of the total 4gb would suddenly become hardware reserved. At 1st i thought faulty ram and ran the 2 modules seperately and ran memtest on both modules seperately and together. Both passed serveral long tests. I finally updated the motherboards bios from version F5 to version F7 (which apparently has enhanced memory support). Finally the memory related problems ceased (like almost 2000+ mb of ram becoming system reserved), but the windows getting stuck at loading etc continued happening.

Off late a new problem started - There would be no display. The computer would boot (you can even hear windows startup in the speakers) but absolutely no display. Not even BIOS or POST screens would display inspite of successful boot up and windows loading. This led me to believe a faulty graphic card so i unplugged the graphic card and plugged it into my other computer (its an E8400 with a Gigabyte P45T-UD3 Mobo and 8 gb of DDR3 Kingston Ram, and it normally runs a Radeon HD 4870X2). On this computer the PC fails to boot completely when i plug the Radeon 5750 which i beleived to be faulty.

What i cannot understand is that on my new computer with the 5750 the computer boots but there is no display (the thing to note is that sometimes the display is normal but sometimes there is none). On the other hand when i plug in the 5750 in my old computer the PC completely fails to boot. There is 1 Long beep followed by 2 short beeps which according to the manual indicates a faulty Video card.

Anyhow i took the gfx card to the store where i bought it from and he tested it and it ran fine on his test bed. Needless to say i was a bit confused. To do a bit mroe testing i bought a cheap Nvidia 8400GS on my way back and tested the new computer with this card and it runs as stable as any computer . As soon as i plug in the 5750 the display problems start. Sometimes the pc boots as normal with display and evrything and sometimes there is no display. And on my older computer it completely fails to boot still.

Im at my wits end as to what the problem here is. Im inclined to beleive that it has to be the gfx card for 2 reasons. One that the 8400GS runs stable on the new comp and second that the 5750 on my older computer results in boot faliure with a long beep and 2 short ones. But the store person says the card is fine and wont replace it or send it for repairs.

Any insight into this will be highly appreciated.
April 21, 2010 2:03:40 PM

Well with the guy testing it at the store and running fine, and a different card in your computer makes it run fine. I would suggest doing a complete removal of the drivers, and reinstalling. As it starting to sound more like a software problem then a hardware problem.
m
0
l
April 21, 2010 2:27:46 PM

Another thing i failed to mention is that the 5750 is recognised in my device manager/dx diag and even Catalyst control panel as ATI 5700 Series and not ATI Radeon 5750 specifically. Is this how it should be or is something wrong? I have the latest drivers Catalyst 10.3 installed.
m
0
l
Related resources
April 28, 2010 2:08:27 PM

Strange Mo. I have a very similiar problem with my hd 5750, and am really pulling my hair out over this one.

I have recently put together a new build with a phenom IIx2 550 (unlocked to a quad) paired with a HD 5750 (1Gig, Pci-e 2) on a Gigabyte mobo (ma770t-ud3p). Worked fine for a few days, until it developed a fault: no post and error beep (1 long and 2 short, indicating a problem with the graphics card). When I put my old card in place of the new hd 5750, everything worked fine. Therefore, I returned the card, and received a replacement. With the replacement card, everything worked fine again for a couple of days, but then, after a long stint of playing Bad Company 2, the same fault appeared: no post, same error beep. So, I worked out that my power supply wasnt a very good one, so I assumed it was to blame, but the Psu I bought to replace it- only marginally better than the last, but certainly with plenty of headroom to cover my power consumption- did not fix the problem.

What I cant do is put this replacement HD 5750 into another computer to check if its faulty, as I dont have another computer, and am out in the country.

I have uninstalled the old drivers, but this did not work.

I am hanging on the edge of my seat for a suggestion...
m
0
l
May 1, 2010 5:41:57 AM

Update. I had my system checked over by a tech yesterday. He was able to isolate the fault to the motherboard.
m
0
l
!