Sign in with
Sign up | Sign in
Your question

Can't turn on fast user switching

Last response: in Windows XP
Share
Anonymous
January 29, 2005 9:35:09 PM

Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

I have a new Dell laptop (inspiron 9200) with 1 GB of RAM running XP Pro. I
cannot turn on fast user switching. When I turn it on, either using the
check box in the Users control panel applet under "login" or by editting the
registry directly (the HKLM\software\microsoft\windows
nt\currentversion\winlogon\allowmultipleTSSession setting) the change doesn't
stick - the registry entry or the check box reverts to the zero or unchecked
state.

The computer is not part of a domain (though it may once have been), there
doesn't appear to be any third party software issues that I can find, and the
Windows XP "welcome" screen is enabled and works.

I tried starting the fastuserswitchingcompatibility and the terminalservices
services (actually the latter was already running) to no avail.

Any suggestions?

Thanks!!

More about : turn fast user switching

Anonymous
January 30, 2005 10:00:28 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

Fast user switching is dependent on 2 services namely "Terminal Services"
and "Fast User Switching Compatibility".

1. Click Start -> Run

2. Type "services.msc" (without quotes)

3. See if the services "Terminal Services" and "Fast User Switching
Compatibility" is started. If the service is not started, set the startup
type to "Automatic"

If still problems -

This is a registry fix for FSU to work properly. Usual caveats re: backup
registry first.

Copy the lines to a text editor like notepad and save the file as
FSUfix.reg. Then double click the file.


--------------------- begin copy below this
line -----------------------------
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\]
"AllowMultipleTSSessions"=dword:0000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService]
"ErrorControl"=dword:00000001
"ObjectName"="LocalSystem"
"Start"=dword:00000003
"Description"="Allows multiple users to be connected interactively to a
machine as well as the display of desktops and applications to remote
computers. The underpinning of Remote Desktop (including RD for
Administrators), Fast User Switching, Remote Assistance, and Terminal
Server."
"DisplayName"="Terminal Services"
"DependOnService"=hex(7):52,00,50,00,43,00,53,00,53,00,00,00,00,00
"Type"=dword:00000020
"ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
00,76,00,63,00,68,00,6f,00,73,00,74,00,2e,00,65,00,78,00,65,00,20,00,2d,00,\
6b,00,20,00,6e,00,65,00,74,00,73,00,76,00,63,00,73,00,00,00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters]
"ServiceDll"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,\
00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\
74,00,65,00,72,00,6d,00,73,00,72,00,76,00,2e,00,64,00,6c,00,6c,00,00,00
"Certificate"=hex:01,00,00,00,01,00,00,00,01,00,00,00,06,00,5c,00,52,53,41,31,\
48,00,00,00,00,02,00,00,3f,00,00,00,01,00,01,00,79,fd,d0,7a,a7,73,b5,a5,5a,\
9d,2d,88,2b,89,b0,df,bb,b7,60,25,5e,00,77,25,69,a5,0f,6d,85,73,e4,db,ab,5c,\
1c,da,a3,bc,44,68,f8,dd,ec,d9,eb,8c,f9,c7,99,3d,d4,4a,2e,72,03,13,2d,c8,8f,\
7f,8f,bf,8f,a6,00,00,00,00,00,00,00,00,08,00,48,00,e9,a4,bc,a5,8e,b2,4d,78,\
e7,26,20,36,12,a2,05,e1,a0,a3,8e,ad,01,9b,d1,a6,ee,d1,e0,ed,e8,bd,61,2c,a1,\
d8,1b,72,32,63,cb,8b,b5,05,2f,36,dd,ac,dc,ac,7d,b5,23,3f,c3,81,9c,f4,dc,73,\
d7,4e,a2,24,09,67,00,00,00,00,00,00,00,00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Performance]
"Close"="CloseTSObject"
"Collect Timeout"=dword:000003e8
"Collect"="CollectTSObjectData"
"Open Timeout"=dword:000003e8
"Open"="OpenTSObject"
"Library"="perfts.dll"
"Last Counter"=dword:00000886
"Last Help"=dword:00000887
"First Counter"=dword:00000806
"First Help"=dword:00000807
"Object List"="2054 2176"
"Library Validation
Code"=hex:00,60,9f,30,0e,2c,c1,01,00,30,00,00,00,00,00,00
"WbemAdapFileSignature"=hex:7e,fd,21,14,ea,d1,ac,72,34,26,10,d7,19,2b,fb,32
"WbemAdapFileTime"=hex:00,60,9f,30,0e,2c,c1,01
"WbemAdapFileSize"=dword:00003000
"WbemAdapStatus"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Enum]
"0"="Root\\LEGACY_TERMSERVICE\\0000"
"Count"=dword:00000001
"NextInstance"=dword:00000001

--------------------- end copy above this line -----------------------------
--
~john aka: jopa



"alexm" <alexm@discussions.microsoft.com> wrote in message
news:3B623642-B613-4C00-B711-532244B0BEC0@microsoft.com...
>I have a new Dell laptop (inspiron 9200) with 1 GB of RAM running XP Pro.
>I
> cannot turn on fast user switching. When I turn it on, either using the
> check box in the Users control panel applet under "login" or by editting
> the
> registry directly (the HKLM\software\microsoft\windows
> nt\currentversion\winlogon\allowmultipleTSSession setting) the change
> doesn't
> stick - the registry entry or the check box reverts to the zero or
> unchecked
> state.
>
> The computer is not part of a domain (though it may once have been), there
> doesn't appear to be any third party software issues that I can find, and
> the
> Windows XP "welcome" screen is enabled and works.
>
> I tried starting the fastuserswitchingcompatibility and the
> terminalservices
> services (actually the latter was already running) to no avail.
>
> Any suggestions?
>
> Thanks!!
Anonymous
January 30, 2005 10:00:29 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

Thanks, but those don't fix it. The problem is that the
allowmultitpletssessions registry key is turned off by windows as fast I can
turn it on - or so it seems.



"jopa66" wrote:

> Fast user switching is dependent on 2 services namely "Terminal Services"
> and "Fast User Switching Compatibility".
>
> 1. Click Start -> Run
>
> 2. Type "services.msc" (without quotes)
>
> 3. See if the services "Terminal Services" and "Fast User Switching
> Compatibility" is started. If the service is not started, set the startup
> type to "Automatic"
>
> If still problems -
>
> This is a registry fix for FSU to work properly. Usual caveats re: backup
> registry first.
>
> Copy the lines to a text editor like notepad and save the file as
> FSUfix.reg. Then double click the file.
>
>
> --------------------- begin copy below this
> line -----------------------------
> Windows Registry Editor Version 5.00
>
> [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\]
> "AllowMultipleTSSessions"=dword:0000001
>
> [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService]
> "ErrorControl"=dword:00000001
> "ObjectName"="LocalSystem"
> "Start"=dword:00000003
> "Description"="Allows multiple users to be connected interactively to a
> machine as well as the display of desktops and applications to remote
> computers. The underpinning of Remote Desktop (including RD for
> Administrators), Fast User Switching, Remote Assistance, and Terminal
> Server."
> "DisplayName"="Terminal Services"
> "DependOnService"=hex(7):52,00,50,00,43,00,53,00,53,00,00,00,00,00
> "Type"=dword:00000020
> "ImagePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
> 74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
> 00,76,00,63,00,68,00,6f,00,73,00,74,00,2e,00,65,00,78,00,65,00,20,00,2d,00,\
> 6b,00,20,00,6e,00,65,00,74,00,73,00,76,00,63,00,73,00,00,00
>
> [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters]
> "ServiceDll"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,\
> 00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\
> 74,00,65,00,72,00,6d,00,73,00,72,00,76,00,2e,00,64,00,6c,00,6c,00,00,00
> "Certificate"=hex:01,00,00,00,01,00,00,00,01,00,00,00,06,00,5c,00,52,53,41,31,\
> 48,00,00,00,00,02,00,00,3f,00,00,00,01,00,01,00,79,fd,d0,7a,a7,73,b5,a5,5a,\
> 9d,2d,88,2b,89,b0,df,bb,b7,60,25,5e,00,77,25,69,a5,0f,6d,85,73,e4,db,ab,5c,\
> 1c,da,a3,bc,44,68,f8,dd,ec,d9,eb,8c,f9,c7,99,3d,d4,4a,2e,72,03,13,2d,c8,8f,\
> 7f,8f,bf,8f,a6,00,00,00,00,00,00,00,00,08,00,48,00,e9,a4,bc,a5,8e,b2,4d,78,\
> e7,26,20,36,12,a2,05,e1,a0,a3,8e,ad,01,9b,d1,a6,ee,d1,e0,ed,e8,bd,61,2c,a1,\
> d8,1b,72,32,63,cb,8b,b5,05,2f,36,dd,ac,dc,ac,7d,b5,23,3f,c3,81,9c,f4,dc,73,\
> d7,4e,a2,24,09,67,00,00,00,00,00,00,00,00
>
> [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Performance]
> "Close"="CloseTSObject"
> "Collect Timeout"=dword:000003e8
> "Collect"="CollectTSObjectData"
> "Open Timeout"=dword:000003e8
> "Open"="OpenTSObject"
> "Library"="perfts.dll"
> "Last Counter"=dword:00000886
> "Last Help"=dword:00000887
> "First Counter"=dword:00000806
> "First Help"=dword:00000807
> "Object List"="2054 2176"
> "Library Validation
> Code"=hex:00,60,9f,30,0e,2c,c1,01,00,30,00,00,00,00,00,00
> "WbemAdapFileSignature"=hex:7e,fd,21,14,ea,d1,ac,72,34,26,10,d7,19,2b,fb,32
> "WbemAdapFileTime"=hex:00,60,9f,30,0e,2c,c1,01
> "WbemAdapFileSize"=dword:00003000
> "WbemAdapStatus"=dword:00000000
>
> [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Enum]
> "0"="Root\\LEGACY_TERMSERVICE\\0000"
> "Count"=dword:00000001
> "NextInstance"=dword:00000001
>
> --------------------- end copy above this line -----------------------------
> --
> ~john aka: jopa
>
>
>
> "alexm" <alexm@discussions.microsoft.com> wrote in message
> news:3B623642-B613-4C00-B711-532244B0BEC0@microsoft.com...
> >I have a new Dell laptop (inspiron 9200) with 1 GB of RAM running XP Pro.
> >I
> > cannot turn on fast user switching. When I turn it on, either using the
> > check box in the Users control panel applet under "login" or by editting
> > the
> > registry directly (the HKLM\software\microsoft\windows
> > nt\currentversion\winlogon\allowmultipleTSSession setting) the change
> > doesn't
> > stick - the registry entry or the check box reverts to the zero or
> > unchecked
> > state.
> >
> > The computer is not part of a domain (though it may once have been), there
> > doesn't appear to be any third party software issues that I can find, and
> > the
> > Windows XP "welcome" screen is enabled and works.
> >
> > I tried starting the fastuserswitchingcompatibility and the
> > terminalservices
> > services (actually the latter was already running) to no avail.
> >
> > Any suggestions?
> >
> > Thanks!!
>
>
>
!