Sign in with
Sign up | Sign in
Your question

NVIDIA nForce Networking Controller Issue

Last response: in Networking
Share
March 2, 2010 6:06:19 AM

I've got this weird problem with the Ethernet controller on my Windows Home Server system. I cannibilized an old Gigabyte mobo with a Pentium-D for WHS, and it has an on-board NVIDIA nForce Ethernet controller on it.

When I'm reading data FROM the server, like copying a file from the server to one of my machines, the connection is beautiful. The number of retransmitted segments is almost nil.

However, when I'm sending data TO the server, like copying a file to a shared folder on it, the segments retransmitted is absolutely awful - like a 60% to 75% retransmit rate.

It doesn't matter which computer on the network is sending or receiving - the result is the same. I've got 2 XP machines and 2 Win 7 machines, and all have identical results.

It's all going through a 3Com Office Connect Gigabit 8 unmanaged switch.

I've tried changing cables and switch ports. All of the cables in the house are Cat 6.

I've fiddled with the settings for the WHS' ethernet controller and nothing seems to make a difference (however, when I turn flow control off nothing works at all).

I can't seem to locate a manual for this controller, so I'm kind of in the dark here.

Here are my settings for the NVIDIA nForce Networking Controller in my WHS. Can anyone see a problem?

ASF Event0 - Boot Failure: Enable
ASF Event1 - Fan Problem: Enable
ASF Event10 - Case intrusion: Enable
ASF Event4 - Heartbeat: Enable
ASF Event6 - Power button pressed: Enable
ASF Event7 - System Hot: Enable
ASF Event8 - CPU Overheated
ASF Heartbeat interval (seconds): 600
ASF Managing Station IP address: Not Present
ASF PET Packet Send Count: 1
ASF Support: Disable
Checksum Offload: Enable
Flow Control: Enable
IEEE802.1P Support: Disable
Jumbo Frame Payload Size: 4500 (was 1500, changed to 4500, no effect)
Low Power State Link Speed: Enable
Network Address: Not Present
Optimize for: Throughput (was CPU, changed to Througput, no effect)
Segmentation Offload: Enable
Speed/duplex settings: Full autonegotiation
VLAD Id: 1
VLAN Support: Disable
WakeOnLAN From PowerOff: Disable

What are those ASF settings, anyway?

Many thanks to anyone who can help me solve this problem.
March 2, 2010 10:44:09 AM

Try a pci nic. It is possible the onboard nic has gone bad.
Check the wires in the nic. Make sure they are straight and not bent at all.

Do you have any problems transferring or receiving files directly from other computers?
m
0
l
March 2, 2010 2:34:48 PM

Sturm,

Thanks for your reply, and thanks for suggestion that I check file transfers between other computers on my network.

Well, I took the WHS out of the picture and sent a big file from a Win 7 machine to an XP machine and there were no retransmits. However, when I went from XP to a Win 7 machine, the same problem recurred.

So it is NOT the Ethernet controller on the WHS machine.

Right now, I'm at a loss to explain. Let me do some more debugging work to see if I can more tightly isolate the problem.

m
0
l
March 3, 2010 4:32:34 PM

I found the problem!

It was the "Large Send Offload" NIC setting which was enabled on several machines. When I disabled it on all machines, the segment retransmit rate dropped to near zero across the board with extensive tests in both directions (sending and receiving files).

I don't know if it was causing a conflict with the switch or if it was at the machine level, but now throughput is unencumbered.
m
0
l
!