Sign in with
Sign up | Sign in
Your question
Solved

Nvidia GeForce 9400GT Conflict..??

Tags:
  • Nvidia
  • Video
  • Geforce
  • Graphics
Last response: in Graphics & Displays
Share
April 23, 2010 5:22:04 PM

I have a Dell Inspiron 530S and have installed an Nvidia GeForce 9400GT card for gaming. The card works really well, but I have a "problem". When I exit the game, the video does all sorts of gymnastics with the colors, until it finally settles down to the desktop with some horrific colors. I have to go into the Nvidia control panel to reset the color to 32 bits, since they end up at 8 bits after the "gymnastics". I have been advised that the card may be in conflict with the onboard video chipset that is the stock video controller from the factory. It's been suggested that I need to disable this chipset via the BIOS. I'm running Vista 32, and the game's video setting is the same as the "normal" setting (1360x768 @ 60Hz). I have also updated the card's drivers regularly. The last update was done a few days ago.
Couple of questions:
1- Is the advice/assesment correct. Do I need to disable the chipset?
2- If so, how do I go about doing this?
I'm somewhat more computer savvy than your regular Joe, but don't want to get in over my head....

Thanks for any help/advice.

Gus.

More about : nvidia geforce 9400gt conflict

April 23, 2010 5:45:00 PM

If this issue began after the recent driver update, I suggest using the previous driver versions. Driver updates are not mandatory and are only truly necessary when they offer performance improvements for specific hardware or within specific software or games.

Basically, if your system is working fine, there's no need to update the drivers.
m
0
l
April 23, 2010 6:47:35 PM

Sorry...Neglected to mention this has been going on since day 1.....

I have also tried turning Vista Aero off, setting appearance to Vista Basic and Windows Traditional....all with no positive results.....

Gus.
m
0
l
Related resources

Best solution

April 23, 2010 8:24:32 PM

There is an obvious potential for conflict with the on-board graphics if it's still enabled. Windows Vista does not permit two completely different video drivers to be used simultaneously. You should disable to on-board IGP, and this does need to be done within the BIOS. You should find it under the heading "Integrated Peripherals" or something similar. Don't forget to uninstall it's drivers when done.

If disabling the IGP doesn't fix it, I'd take the card back, unless it's far too late for that.... If it won't hold it's settings within Windows then there's a major problem with it. It might take a driver removal and reinstallation to clear up any conflicts.

If your system were running Windows XP, there would be no issue, as it will allow two simultaneous video drivers to be run. Windows 7 can with some hacking about, but it's troublesome.
Share
April 30, 2010 3:21:14 AM

Update....I was advised to try running the game as Administrator and to run it in XP Compatible mode. I did that, but with no result. While I was in the properties screen, I decided to "experiment" with other settings. I turned off the 256 color setting, and...EUREKA..!! That worked...!! So I've got a game that is behaving as it should.

Thanks for your suggestions. I did not have to mess with the BIOS, or drivers...(Dodged that bullet..)
m
0
l
April 30, 2010 3:21:28 AM

Best answer selected by Gamernine.
m
0
l
!