Sign in with
Sign up | Sign in
Your question

Switched from IDE to AHCI and now Win7 x64 wont Sleep

Last response: in Motherboards
Share
February 17, 2011 12:02:59 AM

Hello to everyone:

Tittle for this: Problem:"Windows 7 "Sleep Mode" not working after switching to ACHI" and a gift for you all: "Guide: How to change to ACHI easily without reinstalling the whole Win7 OS".

First the PROBLEM: After I changed my settings in my GA X58A-UD3R MB from IDE to ACHI, Windows 7 x64 wont enter in sleep mode. Do you know how to solve this problem ???

Why I changed ???: I needed to install MAC OS 10.6.5 on a different separated hard drive in my PC so I followed this guide. An important step to install the OS is to enable ACHI on the MB. As you can see in this guide:

Second, the gift: I manage to change to ACHI on a GA X58A-UD3R with Windows 7 x64 already installed WITHOUT reinstalling or downloading any driver (Windows 7 reinstalled ALL drivers by it self or downloaded automatically from the web thru "Windows Update"). I followed the steps in this guide, since what I was really trying to do is to install MAC OS 10.6.5 in a second different HD. One of the requirements was to change ACHI in the MB. Gladly they made a guide for changing ACHI without reinstalling Windows 7 again. Well, here is the guide:

Thanks !!!

Xeikon
a c 716 V Motherboard
a b $ Windows 7
February 17, 2011 12:11:19 AM

Try the following.

Check the registry:
"Enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:
Exit all Windows-based programs.
Click Start, type regedit in the Start Search box, and then press ENTER.
If you receive the User Account Control dialog box, click Continue.
Locate and then click one of the following registry subkeys:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
In the right pane, right-click Start in the Name column, and then click Modify.
In the Value data box, type 0, and then click OK.
On the File menu, click Exit to close Registry Editor."

re - http://support.microsoft.com/kb/922976

m
0
l
a c 235 V Motherboard
a b $ Windows 7
February 17, 2011 12:35:11 AM

^+1...

The link provided by jaquith is the correct way to switch without a reinstall. The original post dealt with Windows 7 RC, which isn't the "full" release version.
m
0
l
February 17, 2011 2:24:25 AM

Thank you jaquith. I didn´t know there was a better way. I checked my registry and those keys were as this:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci Value: 0
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV Value: 3

So I should change only the second one. BUT as everything is working well in my Windows 7 (I solved the sleep problem, at the end I of this I will explain you how) my questions is: What is going to change when I change that value from 3 to 0 in the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV registry string ?????? What is this string used for ???? Thank you so much for your explanation.

I solved the sleep problem by downloading this tool: MCE Standby Tool from this web page:

Description of MCE Standby Tool:


Download Win7 BETA Compatible version mst0.9.102:


I worked very well when I installed the prog (Do not just run it. It has an option for just running it instead of installing it, but if you just run it it won´t let you use all its features)

I checked "S3 - Stand by" in the tab "Sleep State". With just that, Sleep worked fine.

Thanks for your help !!!

Xeikon
m
0
l
a c 716 V Motherboard
a b $ Windows 7
February 17, 2011 1:08:50 PM

Changes:
Use 'Fix It" or manually change:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci Value: 3 [b said:
-> Value: 0
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV Value: 3 -> Value: 0

Boot into BIOS and change your SATA -> AHCI, Save & Exit = Yes.

"I checked "S3 - Stand by" in the tab "Sleep State"" ; Correct use: ACPI Suspend Type -> S3(POS)]Changes:
Use 'Fix It" or manually change:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci Value: 3 -> Value: 0
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV Value: 3 -> Value: 0

Boot into BIOS and change your SATA -> AHCI, Save & Exit = Yes.

"I checked "S3 - Stand by" in the tab "Sleep State"" ; Correct use: ACPI Suspend Type -> S3(POS)
[/b]

I don't know about 'MCE Standby Tool', and I would recommend that you start with the following (2) articles before adding an App:

Sleep Settings -> http://support.microsoft.com/kb/976877
Generate a report -> http://support.microsoft.com/kb/976034 ; you may need to move the HTML report to your desktop.

Review the report, chances are there will be several USB items listed, and typically they won't keep your PC from sleeping.
m
0
l
December 17, 2011 7:30:03 PM

Just change the ahci line to 0 then change in bios and your good, for changing to ahci mode.
m
0
l
!