Sign in with
Sign up | Sign in
Your question
Solved

Dell 3000 Can't install Windows XP

Tags:
  • Hard Drives
  • Windows XP
  • Components
Last response: in Components
Share
August 2, 2010 1:22:36 PM

Hello,

I hope this post is in the right area.

I have a Dell 3000 I am working on, trying to reinstall Windows XP-home.

In the BIOS it says the "hard drive not installed" when I put in the Windows XP CD it runs through the setup: loading files, hit F8, copying files with no errors. It gets to the point where it needs to restart, and it goes through the whole process again and keeps doing that.

I tried another good hard drive and the same thing. I tried switching around the settings in the BIOS and still nothing. I pull out the CD and it beeps and gives F1 to try reboot or F2 to enter setup. I Hit 'R' for Repair Windows and I can go in to Recovery Console. The files are there on the hard drive so it is writing to the hard drive.

With the windows CD I deleted the partition and reformatted the drive, created a new partition that seem to work well. I also tried different CD's it just keeps looping through setup process. I tried plugging the hard drive in to both IDE on board controllers and get the same thing.

Anyone have any ideas or know what I am missing here!

I am told it worked fine a week or two ago. The person who owns it tried to do a memory upgrade but had the wrong ram so they put the old ram back in that's when it started not seeing the hard drive. I checked all the connections. Help!

Ken


More about : dell 3000 install windows

August 3, 2010 2:24:25 AM

After it restarts, just don't hit a key when it has the prompt. It will bypass booting off the CD, and continue the install off the hard drive.

m
0
l
Related resources
August 3, 2010 2:34:21 AM

Download, Parted Magic, a live cd distribution of linux, reformat your hard drive using the NTFS format. Then it should pop up and work!
m
0
l
August 3, 2010 3:53:08 PM

Aford10,

Thanks for the reply. I don't hit any keys.

It gets to the point where it needs to restart and it just re-starts the whole process of going through the setup again. I have it set in BIOS to boot from the hard drive.

I have tried other good hard drives and install CD's I get the same thing, so I'm not sure that Parted Magic will help but I will try it. Again it wrights the files to the hard drive is setup it just wont boot. it beeps and gives F1 to try reboot or F2 to enter setup. I reset the BIOS by pulling the battery and letting it sit for 3 hours.

I am so lost on this one!

Thanks

Ken

m
0
l
August 3, 2010 4:11:39 PM

In the BIOS, there is an option to halt on errors. It's usually set to halt on keyboard errors. Try disabling that, and make sure your keyboard/mouse interface (USB or PS2) is enabled.
m
0
l
August 3, 2010 4:30:15 PM

Aford10

I check the BIOS the keyboard setting it has is "report keyboard errors" I disabled that. The keyboard and mouse are USB, the keyboard seems to be working ok. I saved the settings and with out hitting any keys it goes right in to " Setup is inspecting your computers configuration"

Thanks

Ken
m
0
l
August 3, 2010 4:40:11 PM

Now you should be able to do your install. :) 

Just make sure USB mouse/keyboard are enabled in the BIOS.
m
0
l
August 3, 2010 5:06:01 PM

Keyboard and mouse are enabled. Just went through it again, it copy's the files to the hard drive it gets to the point where the pc is rebooted and then just goes through the setup again.

It wont go in to windows, it's like there is some communication not taking place when it reboots. It cant see the first part of the setup has been completed.

m
0
l
August 3, 2010 5:44:22 PM

Is it still showing the F1, F2 prompt on restart?
m
0
l
August 3, 2010 6:01:09 PM

Only if there is no CD in the drive.

When it is done copying the setup files to the hard drive it says " This part of the setup is complete. Your computer needs to be restarted" it goes through the reboot process and starts the setup all over again.
m
0
l
August 3, 2010 6:19:20 PM

Have you set the bios ex. set the time up and what not? Same thing happened on my first build.
m
0
l
August 3, 2010 6:31:20 PM

Check your boot options in the BIOS. Make sure the hard drive is listed as the 2nd boot device.

After it copies the setup files, unplug your keyboard. Unless a key is being pressed, it should bypass the CD and boot to the hard drive.
m
0
l
August 3, 2010 7:01:10 PM

Computerrock1,

Yes I set the time and date. It has the most current BIOS version also, seems it just can't get past the first part of the setup.

When you go in to boot sequence it says the hard drive is not installed, however when you go in to Drive configuration, under primary drive it shows the drive.

I first thought it could be a bad controller, but it wrights the files to the drive.



m
0
l
August 3, 2010 7:04:37 PM

So there isn't a hard drive option in the boot sequence?

It may not be listed by name. But it should have a hard drive option in there.
m
0
l
August 3, 2010 7:31:43 PM

Aford10,

It went through the process again and I unplugged the keyboard and it still went right in to the setup again. This makes no since I may try flashing the BIOS just to see what that may do.

m
0
l
August 3, 2010 7:46:10 PM

Aford10

in the boot sequence it list in order
1. "boot to CD Rom device"
2. "boot to Hard drive (Not Installed)"

The hard drive is installed and it wrights the files to the hard drive. If I Hit 'R' for Repair Windows and I can go in to Recovery Console Dos screen, all the install files are there on the hard drive. It just will not boot in to windows, instead it starts the setup all over again.

In the Drive configuration where it list the primary, slave drives it shows my drive as primary Master drive. It shows the CD Roms as secondary Master drive.


m
0
l
August 3, 2010 7:46:19 PM

Are there any errors when it's copying the files?
m
0
l
August 3, 2010 7:50:20 PM

In the recovery console, run the following commands:
chkdsk /r
fixboot
fixmbr
bootcfg /rebuild
m
0
l
August 3, 2010 7:52:58 PM

At this point, I would say its the motherboard, I remember hearing that a dell computer must have the oem's os cd
m
0
l
August 3, 2010 7:53:56 PM

Nop!

I get no errors at all, it copies the files just fine. I have installed XP many times it all looks normal. When it reboots it should go in to windows to finish the install, but instead to goes back to the start of setup.
m
0
l
August 3, 2010 7:55:06 PM

The CD is OEM and in good shape.
m
0
l
August 3, 2010 8:44:56 PM

Ok I run the following commands In the recovery console:

chkdsk /r
fixboot
fixmbr
bootcfg /rebuild

No help still does the same thing goes back to setup:( 

m
0
l
August 3, 2010 8:54:55 PM

I'm sure the problem lies in the boot sequence showing the hard drive as not installed.

Are there other options, such as boot devices, that may have the hard drive disabled? All BIOSs are a little different, so I'm not sure what options you have.

Have you tried disconnecting the cable, or switching it completely? Checked the jumper setting?
m
0
l
August 3, 2010 9:29:32 PM

I have Checked the jumper setting, I have not switched out the cable yet but am going now to get one. I will let you know what happens.

The BIOS Options are:

system time
system date

Drive configuration.
Boot Sequence

Memory Information
CPU Information

Integrated Devices
Power Management
System Security

Keyboard Num lock On: On
Report Keyboard Errors: Disabled

Auto Power On: Disabled!
Fast Boot: Off

OS Install mod: Disabled

Limit CPUID: Disabled

IDE Hard Drive Acoustic Mode: Bypass

System Log

Asset Tag




m
0
l
August 3, 2010 9:47:15 PM

Yes, turn the OS install mode ON.

It's a feature that I've only seen on a few Dell models.
m
0
l
August 3, 2010 9:48:18 PM

The OS install mod limits the PC to 256mb of memory when installing the OS, I have it disabled but have tried it also it was no help.

m
0
l
August 3, 2010 9:55:49 PM

Did you set the boot order? HD starts first.
m
0
l
August 3, 2010 9:56:09 PM

Yes, that's a normal message when enabling that.

What's in Drive Configuration?
m
0
l
August 3, 2010 10:54:47 PM

It shows my drive as primary Master drive primary Slav is off. It shows the CD Roms as secondary Master drive and secondary Slav is off.

Tried new ribbon cable that didn't help. I really thik we are down to a motherboard problem here.
m
0
l

Best solution

August 3, 2010 10:58:29 PM

I'm officially out of ideas.
Share
August 3, 2010 11:23:48 PM

Me as well,

Thank you for all your help and time, It's time to toss in the towell!!

Thanks everyone

Ken
m
0
l
August 11, 2010 12:07:18 AM

Best answer selected by krosloniec49426.
m
0
l
!