Sign in with
Sign up | Sign in
Your question
Solved

BIOS not recognizing memory

Tags:
  • Memory
  • BIOS
  • RAM
  • Product
Last response: in Memory
Share
February 21, 2011 6:06:17 PM

Hi, I recently decided to upgrade to windows 7 64bit home premium and upgrade the ram in my pc. I originally had 1gb(Corsair XMS2 DDR2 2X512MB) of ram installed with win xp. So i bought new ram 2x2gb of corsair xms2 ddr2 and win7 64bit. I installed the ram, installed win7 everything runs nice and smooth. My problem is my BIOS only read that i have 3225mb of ram, first thing that came to mind was switching the ram around trying different slots. But before i did i checked out dxdiag, cpu-z, and system info. Dxdiag shows i have 3326mb of memory and where page file is it says i have 1422mb used and 5229mb of memory aval. With cpu-z it shows i have 5120mb, and it shows all of my ram is registering right. Yet looking at windows sys info it shows 3.25gb of memory.. I'm at a loss of things to try. I've tried updating the BIOS but MSI hasn't come out with an updated BIOS for win7 (that i know of) and everytime i try to update it tells me it doesn't support the OS. I've tried the msconfig>advanced options and unchecking max memory...nothing.. I'd dont know what else i can try doing, should i try reseating the ram or what? I'm at a loss right now and confused. Any help would be greatly appreciated.

Here are my sys specs
mobo- MSI P965 Neo (Supports up to 8gb)
proc- Intel P4 Core 2 Duo E6600
Mem- Corsair XMS2 DDR2 800MHZ 2x2gb and 2x512mb (5gb)
Vid- ATI Radeon x1900 512mb



More about : bios recognizing memory

a c 347 } Memory
February 21, 2011 7:25:32 PM

Welcome to Tom's Forums! :) 

Three probable causes:
1. Mix-Matched RAM {Frequency, CAS, Timings, Voltage, Type including chips/side SS/DS}.
2. Incorrect DIMM Slots:
CPU: | 2GB | 512MB | 2GB | 512MB |
3. BIOS - including Memory remapping.

Q - Need RAM info; please post a link and/or part numbers. If needed use CPUz use SPD tab and Google the part number(s).
Q - Post the Resource Monitor info as below.

Suggestions:
1. Clear CMOS
2. Install only the 2GB -> CPU: | 2GB | empty | 2GB | empty |
3. Clear Maximum Memory:


Resource Monitor:
m
0
l
Related resources
a c 347 } Memory
February 21, 2011 10:56:47 PM

Different CAS and Voltage mix. What about the recommendations above? What about the slots? {review manual page 2-7 (23 pdf), and 3-22 (59 pdf).

ref - http://us.msi.com/index.php?func=proddesc&maincat_no=1&...

800 MHz 5-5-5-18 2T 1.8v 2G
800 MHz 5-5-5-15 2T 1.9v 1G
==================
800 MHz 5-5-5-18 2T 1.9v Mixed

At the very least you'll need to increase the DRAM Voltage {a/k/a Memory Voltage} = 1.90~1.95v. Next, if needed and 1GB are running, set the CAS timings, see 3-10 (47 pdf).

Again, what happens if "2. Install only the 2GB -> CPU: | 2GB | empty | 2GB | empty |"?

m
0
l
February 21, 2011 11:03:49 PM

i was just about to clear cmos and try just the 2x2gb. so i'll try it and see what happens. if that doesnt work ill try upping to volt.
m
0
l
February 21, 2011 11:06:05 PM

and i have them slotted as is cpu: |2gb|512mb|2gb|512mb
m
0
l
February 21, 2011 11:40:22 PM

so i cleared the cmos and tried just the 2x2gb set like this cpu> 2gb|empty|2gb|empty

bios and windows are still showing 3.25 and cpu-z is showing the 4gb.. There is a bios update that fixes the bios to recognize 4gb. i tried to update to the latest but it wont upgrade because im running win 7, there any way around this?and how would raising the voltage and changing the timings fix this? I thought that was more so for O/C?
m
0
l

Best solution

a c 347 } Memory
February 22, 2011 12:50:27 AM

Yeah, if you're running pre-1.5 then update your BIOS. Regarding voltage, no that not overclocking - one problem you have is the RAM has different voltages and the CAS timings are slightly different.

Upgrading the BIOS, use BIOS version 1.11 or the latest version. Typically, I prefer updating from the BIOS itself using a USB Flash drive {FAT32}. In noted there's a Windows utility 'MSI Live Update 5'. Anytime you flash a BIOS go in the BIOS an Load Default first.

MSI USB Flashing -> http://service.msicomputer.com/html/popup/CustService/i...

edit: Question, do you have a 32-bit OS connected to your PC in any way and/or partitions?
Share
February 22, 2011 1:30:38 AM

Yeah the version thats on here is pre 1.5 but theirs no way i can update it...ill have to go out and get a usb flash drive and try it that way.. an no i don't have a 32-bit os connected..
m
0
l
February 22, 2011 10:50:20 PM

probelm solved. updating the bios fixed it. thanks for the help.
m
0
l
February 23, 2011 7:13:25 PM

Best answer selected by steveng729.
m
0
l
!