Sign in with
Sign up | Sign in
Your question
Closed

Intel speedstep not working?

Last response: in CPUs
Share
August 2, 2010 6:24:59 PM

Ok so im trying to fix a friends laptop which he complains is extremely slow. Here are the specs:
Intel core2duo t5450 @ 1.66 Ghz
Win vista 32 bit
1 gb ddr2 600 ram (yeah i know)
GMA 965


Ok so the most obvious problem is that it has vista, and only 1 GB OF RAM :pfff: 
Im planning to add an extra gig to speed things up, which i think will work since i noticed when you have even 3 windows open, the ram usage is at least 75%.

But heres the weird part, i checked cpu-z to see more info about the cpu. When i checked it was at .96 v and 900Mhz. I know this is speed step, but it seems to be stuck here! I ran many programs at once including ccleaner to attempt to pull it out of speedstep, but no luck. What should i do?
a b à CPUs
August 2, 2010 7:43:17 PM

Most laptops have locked BIOS,so that's the reason you can't disable speedstep, try running a game (for 10 minutes) or a stress tool(like Prime95,run it for about 5 minutes) and check if the CPU is still stuck at 900Mhz or not
Score
0

Best solution

a b à CPUs
August 2, 2010 7:52:32 PM

Is it set to power saver mode? Usually, on laptops, you can change the battery priority, and on power save mode, it usually locks the CPU to the lowest available clockspeed.
Share
Related resources
August 2, 2010 8:53:23 PM

cjl said:
Is it set to power saver mode? Usually, on laptops, you can change the battery priority, and on power save mode, it usually locks the CPU to the lowest available clockspeed.

Wow i feel like an idiot :pt1cable: 
I changed to balanced from power save and now its working like it should. I have no idea how this eluded me :pfff: 
Score
0
August 2, 2010 8:53:42 PM

Best answer selected by yannifb.
Score
0
a b à CPUs
September 27, 2010 2:54:44 AM

This topic has been closed by Mousemonkey
Score
0
!