Sign in with
Sign up | Sign in
Your question

16GB SD Card Partition Disaster

Last response: in Storage
Share
July 20, 2012 11:52:26 AM

After hours of trying to set my new SanDisk 16GB Extreme SD card up for use as storage for a raspberry pi it has demoralized me! :cry: 

Basically, I had it working on the pi with a Raspbian image that was located on one partition (somehow only taking up 56MB space on the card) another partition that was almost full that I didn't ask for used about 1.7GB of card space and the 3rd partition which I had to create from nothing in a terminal window on the pi itself taking up the rest of the space on the card to be used as a data storage partition. I believe this data partition was ext4 and the partition containing the Raspbian OS was fat32.

So it was all working fine until I attempted to install Quake 3 which was a complete nightmare of terminal based commands, downloads and software that was generally unwilling to comply with anything (long, long story). I eventually came to a point where there was not enough memory left to download some files for Quake 3 on one of the shoddy partitions so I decided to delete some files in a cache folder and lowe and behold, upon next startup the whole thing is buggered and I cant boot.

Anyway, after deciding to bypass the inevitable suicide I was heading for by this point, I attempted to wipe the whole card clean, start a fresh and install a version of Debian that there were clear tutorials for online for how to get Quake 3 running on it.

This did not go to plan!

I mean at all to plan!!!

The whole business of writing the OS to the card had been a real task for some reason to begin with so I decided to delete all the partitions and create one new partition in ext4 filesystem format. This worked and gave me 14.84GB or so of space to write the OS to......brilliant. So it was formatted and I wrote the OS to the one and only partition on the card with Roadkil's Disk Image software. But when it was finished I viewed the Card on MiniTool Partition Wizard Home Edition v7.5 and it displayed the partition as being full and of filesystem "other" instead of ext4! :pfff: 

I've tried spamming the card with zero's and creating all sorts of partitions but to no avail.

The card now seems to be in a state of shock, not being able to take any sort of OS to a partition.

Many, many thanks in advance to whomever assists in this issue as I am keen to get the Pi back up and running, let alone run Quake 3 on it!

Note:
When I now create a new partition on the card there seems to be some space taken up even after formatting! Could this data be from that mysterious 1.7GB partition at the beginning which the computer seemed to allocate itself (Some sort of core files for the SD card that can't be removed)? Anyway, whatever it is it doesn't have a proper home now and is interfering with other partitions like an insistent dosser.
July 20, 2012 12:36:05 PM

That software is what I have been using but it still doesn't seem to work.

A full guide from start to finish on how to create a working partition for an OS would be very helpful.

Thanks
!