Sign in with
Sign up | Sign in
Your question

Low fps at cs:s with HD4870

Tags:
  • Radeon
  • Graphics
Last response: in Graphics & Displays
Share
April 27, 2010 4:05:01 PM

Hey guys, recently I have noticed a bit lower fps at the games I play. I thought it is just a normal thing cause my pc had not been formated nor cleaned outta the dust for a long period of time. I reformatted the computer but the problem prevailed.

My settings are:

e8400
HD4870
Asus P5Q pro
4gb ram

norton epsilon 600w
noctua cpu cooler+ 2 noctua fans

My fps 100-300 but with more people at once it drops to about 50-60.
For example friend of mine has got e3200 and 1950pro and it doesn't drop bellow 150...

I tried several systems (xp/vista, currently on 7 64-bit)
Turned speed step off
cleaned the pc from the dust (well there is still some left but I don't think much)
tried the newest drivers (both w/ or w/o CCC) , even older ones

weird thing:

During stress test GPU load is about 95% (normal), during cs:s or other game it is like this: 0% 0% 0% 17% 0% 0% 0% 0% 32% 0% 0% ... etc

To have the regular temeprature I used to have , about 80C , it is enough to have my GPU fan at 23% (pretty low right?), when I turn it at 50%, GPU temeprature drops to 45C, with only 35% it doesn't get above 55C

Pics of my pc: http://img444.imageshack.us/gal.php?g=pc1o.jpg

thanks in advance

More about : low fps hd4870

April 27, 2010 4:33:59 PM

Make sure you have the right drivers installed. That might mean completely uninstalling with driver sweeoer.

What are the settings you and your friend are running on? An HD4870 might struggle with intense combat @ 1920x1080 w/ all high settings/AA/AF.
m
0
l
April 27, 2010 4:54:45 PM

shadow187 said:
Make sure you have the right drivers installed. That might mean completely uninstalling with driver sweeoer.

What are the settings you and your friend are running on? An HD4870 might struggle with intense combat @ 1920x1080 w/ all high settings/AA/AF.

I did uinstall the drivers using the 'driver sweeper'. My friend is running on an fps config
I am running on dx_81 (tried even 9.c even worse) low details (except shadows) 640x480
m
0
l
Related resources
April 27, 2010 8:29:46 PM

BUmp I am really desperate
m
0
l
April 27, 2010 9:33:17 PM

It honestly sounds like bad drivers. There's no reason you can't game with max settings. Maybe a reformat is necessary.
m
0
l
April 28, 2010 5:26:26 AM

shadow187 said:
It honestly sounds like bad drivers. There's no reason you can't game with max settings. Maybe a reformat is necessary.

I have reformatted like 5times already (using vistas, 7s, xps ) The only system it worked good was a bugged xp 32bit update (was just an update, dunno how did I manage to install it, I installed it on vista version) I just forgot to activate it. When the 30 days passed, I couldn't activate it anyhow, was bugged. The weird thing is that system that worked was the only 32bit I have tried, could the problem be there?
m
0
l
April 29, 2010 2:05:22 PM

bump
m
0
l
April 29, 2010 2:14:46 PM

I've seen the exactly same problem in the past. 100FPS while alone on map , 40-60 FPS when near other players. I though it's the video-card too , but it turned out to be the processor ( a old celeron tho ). I can't tell you that in your case might be the same , but maybe you should check it.
m
0
l
April 29, 2010 2:27:52 PM

why is gpu load on 0% then?
and if it is really a CPU what should I do about it?
m
0
l
May 1, 2010 7:45:28 PM

bump
m
0
l
May 2, 2010 4:57:13 AM

Well is the 30 fps to horrible for you to play????? Thats what I play at on bf2 and seems like 30-35 is the sweet spot for fps.

Do you have any startups running. Start-run-msconfig-startup-. Only 3-5 things running. Run defrag, scandisk, and everthing you can think of.

You have all your drivers updated etc?

512mbs of ram is not enough for online games!!!! This probably is most of it!!!! When I had a 1 gig of ram this was not enough. 1.5-2gigs is enough for right now!...............


About my spelling, If you say anything about it im gonna hunt your nerdy english aniel retentive arrrssse down and beat the elcrapo right out of you!!!!
I came to this planet to chew bubblegum and kick ass! And I am all out of gum!
m
0
l
May 2, 2010 4:59:52 AM

f you have it at high settings, that may be your problem. HDR requires a LOT of power.

The other problem may be:
CPU Info: Intel(R) Pentium(R) 4 CPU 2.40GHz

I have an Athlon XP 2400, and in most games it is CPU limited with just a Radeon 9500. (and if you didn't know, an Athlon XP of similar rating is faster in games than a P4)
m
0
l
!