Sign in with
Sign up | Sign in
Your question

USB not recognize

Last response: in Storage
Share
July 20, 2012 6:16:09 PM

Hello guys! I have a big problem and I need help!! My USB ports (front or back) doesn't work anymore! It happened once before, and I used a MicrosoftFixDevice, or something like that that fixed it. But since a while now I have the same problem and that program aint working anymore .

the program says I don't have my USB drivers anymore, which is weird. So I went to Acer website and got the chipset drivers but it says mines are more recent...
There was no "usb" drivers options.

My PC is a Acer Aspire m3920-e4142

I can't use my Ipod since its dead and need refill, can't use my 1T external hardrive, nor any USB key and I need to put stuff on them for work.... ANY HELP PLEASE?

More about : usb recognize

a b G Storage
July 20, 2012 7:59:16 PM

Here's what my first step would be, if already taken ignore this.
Go into Control Panel >> System >> Device Manager. At the bottom of the list should be your Universal Serial Bus Controllers. You should have USB root hubs listed, update each driver for those especially - but you should actually make sure all your drivers are up to date in there.
m
0
l
July 20, 2012 9:08:08 PM

C12Friedman said:
Here's what my first step would be, if already taken ignore this.
Go into Control Panel >> System >> Device Manager. At the bottom of the list should be your Universal Serial Bus Controllers. You should have USB root hubs listed, update each driver for those especially - but you should actually make sure all your drivers are up to date in there.



I have indeed 1 with no driver. But the problem is Acer doesnt give me any USB drivers. Nor can I find some that look legit.
m
0
l
Related resources
July 20, 2012 9:34:04 PM

and offcourse the auto update tool from windows doesnt work.
m
0
l
July 21, 2012 12:03:23 AM

Those are USB 3.0 I tried em, and instead of going into my download folder, the Zip file when the windows file somewhere, I can find some setup file in it but I cant open it..
m
0
l
a b G Storage
July 21, 2012 1:15:56 AM

Since USB is now native to BIOS (or at least some of it), you might try your bios settings to see if it is enabled and not restricted somehow. You can rapidly hit f12 (some models use CTRL+ALT+ESC which is held) during the startup sequence (before windows) to get into bios. Check out a few vids on your bios settings so you have an idea of what you will see and can do there. I'm kinda reaching now...
Be careful in BIOS, the potential is there to really mess things up.
m
0
l
July 28, 2012 3:17:42 AM

Took me times since I work a lot, but everything is alright in BIOS, 1 of the 1st thing I checked.
m
0
l
a b G Storage
July 28, 2012 4:44:02 AM

A little more digging (and still without for sure paydirt) I did find that it is mentioned that Realtek makes the USB driver and it's version number is 6.0.1.6194. The only driver that matches that description in your support is an audio driver - does that make sense? Might try it for lack of other fixes at the moment
m
0
l
July 28, 2012 10:43:37 PM

I'll try that and I'll be back with results soon! Thx anyway for searching, im in middle of a move to a new appartement and still don't have the internet over there...
m
0
l
July 28, 2012 11:27:15 PM

Only desinstalled and reinstalled it. I have found this,

http://www.justanswer.com/computer/56gz8-usb-devices-no...

Look like disabling the driver signature enforcement (in BIOS) might do the trick, but its kinda sad that I have to do that everytime I need my USB key or harddrive.. well I'll try that tonight and will come back with results!
m
0
l
August 7, 2012 7:11:54 PM

ok.... so it was complicated...and not.

1. turning off signature didnt worked, but (dunno why) made me think of something I installed earlier this summer. I installed a software to use my IPOD without using itunes.
So I deleted it and my USB yellow mark was gone, but still, wasn't working. the driver for my multicard wasnt working now (sd cards, etc).

2. after wondering a bit on wtf was going on (since my SD card were working but the driver said it was not) I decided to do a clean up of my PC.
défragmenteur (dunno what is it in english, my pc is french)
disk cleaner
both software implemented in windows OS.

still nothing.

3. CCleaner. I did a little cleaning with that and....what? USB working now :D  still dunno what was going on ( cookies, temp files, passwords, historique) but I don't think that could cause the problem.. well at least its working now! Thx for those who tried to help me :D 
m
0
l
!