Sign in with
Sign up | Sign in
Your question

HDD died or ...?

Last response: in Storage
Share
July 21, 2012 6:06:27 AM

Folks,

It appears my HD "died" today. It started when I booted up my computer and I got a screen that said, "Please insert a bootable media... something along those lines. My BIOS did not recognize it either. I swapped out my SATA 3 cables for SATA 2 cables and that didn't work. I also tried a different SATA power connector and unplugged and re plugged the connector to a new spot. Could it be that my HDD is dead because Windows was giving me error and warnings prior to the death of my HD. I sent my HD to RMA and hopefully to have a working, new HD by Monday. The brand is HGST/Hitachi and my comp. is iBUYPOWER. What do you guys think?

More about : hdd died

a c 265 G Storage
July 21, 2012 2:53:35 PM

Sounds like it died, BIOS not finding it and moving it between connectors confirms that.
m
0
l
a b G Storage
July 21, 2012 3:56:28 PM

I think if you've already RMA'd the drive you've resovled the issue already.
m
0
l
a c 379 G Storage
July 23, 2012 11:55:54 AM

timesvan32 said:
Folks,

It appears my HD "died" today. It started when I booted up my computer and I got a screen that said, "Please insert a bootable media... something along those lines. My BIOS did not recognize it either. I swapped out my SATA 3 cables for SATA 2 cables and that didn't work. I also tried a different SATA power connector and unplugged and re plugged the connector to a new spot. Could it be that my HDD is dead because Windows was giving me error and warnings prior to the death of my HD. I sent my HD to RMA and hopefully to have a working, new HD by Monday. The brand is HGST/Hitachi and my comp. is iBUYPOWER. What do you guys think?


This was most likely windows reporting back the SMART status of the drive. These errors should not be ignored.
m
0
l
!