Sign-in / Sign-up
Your question
Solved

AMD cpu cooler not clipping on

Tags:
  • CPUs
  • Cooling
  • AMD
  • Product
Last response: in CPUs
August 3, 2010 7:09:59 PM

I have everything ready but I can't seem to attach the cpu cooler. The CPU slid on nicely but the cooler does attach. I put on one clip and the second can't reach the other plastic part (plastic is too short).

This is my first build so I'm probably missing something but it is really making me mad and I can't figure this out.

CPU - AMD phenom II x4 955
MOBO: http://www.newegg.com/Product/Product.aspx?Item=N82E168...

I've applied decent force and it still won't reach. I don't want to press too hard and risk breaking something.

Please help

More about : amd cpu cooler clipping

Best solution

a b à CPUs
August 3, 2010 7:25:37 PM

You need to take a good look at the cooler, make sure its in the open position, and it will go on easy.

Sometimes it helps to put the latch side on first.
Share
August 3, 2010 7:26:37 PM

yeah i did the latch side first this time, applied a bit more pressure and it popped in. hopefully everything else goes smoothly.
m
0
l
Related resources
Can't find your answer ? Ask !
August 3, 2010 7:26:53 PM

Best answer selected by BakedBean.
m
0
l
August 3, 2010 7:34:45 PM

Just make sure it's lined up straight with the plastic tabs on the motherboard retention bracket (black plastic thing with screws in it)... it can be off to one side even if you already secured one of the latches to one of the plastic tabs.

gotta be lined up pretty much perfect otherwise it will be like half a mm out and wont reach

as a last resort you could unscrew a few screws on the retention bracket and see if it helps
m
0
l