Sign in with
Sign up | Sign in
Your question

Catalyst 10.4 out,post your experiences

Last response: in Graphics & Displays
Share
April 28, 2010 6:19:06 PM

And it says it fixes 2D problems,finally :D 
Here is from release notes
Performance Improvements
The following performance gains are noticed with this release of Catalyst™ 10.4:
S.T.A.L.K.E.R. – Clear Sky
Improves up to 6% with ATI Radeon™ HD 5970 graphics products
Improves up to 3% with ATI Radeon™ HD 5800 graphics products
Improves up to 3% on ATI Radeon™ HD 5700 Series products

Resolved Issues for All Windows Operating Systems
This section provides information on resolved issues in this release of the ATI Catalyst™
Software Suite for Windows. These include:
Desktop mouse cursor will no longer intermittently appear enlarged
Pressing the "Page Down" button while configuring the last display in Eyefinity
group will now properly switch to the next display instead of closing the bezel user
interface
Shortcut keys to configure the bezel now functions properly
Resolved Issues for the Windows 7 Operating System
This section provides information on resolved issues in this release of the ATI Catalyst™
Software Suite for Windows 7. These include:
"Battlefield 2: Bad Company" maps no longer takes unusually long to load for ATI
Radeon™ HD 5000 Series
Performance on 2D applications and benchmarks has now been fixed

Catalyst Control Center - Advanced options no longer becomes disabled after
connecting second display in clone mode
Video Gamma now functions properly during SD/HD video playback with Adobe
Flash Player 10.1
Video corruption no longer visible while watching live HD Jade Channel (Hong
Kong) with Windows Media Center
Flashing no longer visible in "Shattered Horizon" game with CrossFire™ enabled
Changing in-game resolution in "Alien vs. Predator" no longer causes screen
flickering under multi-GPU configuration

Tint setting under Catalyst Control Center - Basic Color now displays smooth
transition when adjusted for Blu-ray playback
In-game anti-alias now functions properly when other in-game options like
Volumetric Effects are enabled in "Empire: Total War" and "Napoleon: Total War"
games
Flickering corruption and flashing textures are no longer visible in "Battlefield 2: Bad
Company"

"NecroVisioN" game now launches properly in DirectX 10 mode
Desktop corruption no longer observed on enabling Aero effects or updating graphics
score
Blank screen no longer observed when 8X anti-aliasing is applied in "The Chronicles
of Riddick 2" game

And the download links:
Win 7 32bit:
http://game.amd.com/us-en/drivers_catalyst.aspx?p=win7/...
Win 7 64bit:
http://game.amd.com/us-en/drivers_catalyst.aspx?p=win7/...
XP 32bit:
http://game.amd.com/us-en/drivers_catalyst.aspx?p=xp/ra...
XP 64bit:
http://game.amd.com/us-en/drivers_catalyst.aspx?p=xp64/...
April 28, 2010 7:30:05 PM

Well, I know with the pre-release versions, BF:BC2 definitely sped up in the loading times from 30+ seconds to 5 seconds.

However, I was beginning to get some flickering corruption, especially in the final single-player mission. I might have to install today's release and see if it still happens. It could be my GPU overheating since I've overclocked it, but no other game causes it. And, it only happened in the final mission.
m
0
l
April 28, 2010 8:50:22 PM

I'm still running 9.11 drivers, I'm running a 4 series card and they (AMD) seemed to forget these cards existed after 9.11 when the 5 series cards came out. I was meaning to update to 10.3 as they seemed to have decided to stop focusing on the new cards and getting them running well as they included some decent improvements with 4 series cards in those drivers.
10.4 seems to be back to focusing on specific games with the 5 series cards so i think i will just go with the 10.3 drivers when i get a chance and leave these new ones to those that have the hardware.

Mactronix
m
0
l
Related resources
April 28, 2010 8:59:54 PM

I'm giving them a go right now. Upgrading from 10.3a and hoping they fix some shadow flickering in Dirt 2.
m
0
l
April 28, 2010 9:32:07 PM

Me too,i will install them tomorrow and report back,the main thing i really want is to get rid of 2D problems(which are mostly taken care off with setting the clock to 400/900 but not completely)
m
0
l
April 28, 2010 9:55:56 PM

I uninstalled 10.3a and installed 10.4 . I have a xfx 4770 o/c . Ran 3dmark 06 seem to score a couple hundred points lower. 17,500 vs 17800-18000
Rand TH 2D test scored almost exactly the same as 10.1
I think this model always had good 2d acceleration/ performance, is that not the test where some new cards scored very low , compared to older cards ?
m
0
l
April 28, 2010 10:37:08 PM

9.12 + the HF isn't it supposed to be more stable for 48xx cards?
m
0
l
April 28, 2010 11:05:22 PM

Where can we download that 2-D benchmark? I'll give it a try later on my 4650 and 5850.
m
0
l
April 28, 2010 11:54:16 PM

Thanks Maziar, you're always on the ball when it comes to driver releases.
m
0
l
April 29, 2010 12:17:34 AM

Thanks. I had seen the original article, but no link.
m
0
l
April 29, 2010 12:24:50 AM

My 4650 gets (on a really old driver, just using it to set a low baseline):

BENCHMARK: DIRECT DRAWING TO VISIBLE DEVICE

Text: 40000 chars/sec
Line: 34014 lines/sec
Polygon: 12024 polygons/sec
Rectangle: 6309 rects/sec
Arc/Ellipse: 8977 ellipses/sec
Blitting: 6916 operations/sec
Stretching: 523 operations/sec
Splines/Bézier: 26810 splines/sec
Score: 1576

BENCHMARK: DIB-BUFFER AND BLIT

Text: 28571 chars/sec
Line: 98684 lines/sec
Polygon: 16854 polygons/sec
Rectangle: 2064 rects/sec
Arc/Ellipse: 22831 ellipses/sec
Blitting: 5862 operations/sec
Stretching: 717 operations/sec
Splines/Bézier: 34483 splines/sec
Score: 2081

Now we'll see if my 5850 can beat that. I'll try stock clocks and high 2-D (in a little while).
m
0
l
April 29, 2010 12:54:11 AM

So far all is smooth,though not a noticeable difference in my gaming!
m
0
l
April 29, 2010 2:53:07 AM

Well, I'm fairly impressed. Compare these to the review. Some did not improve, but most were from good to amazing in my opinion!

Review: http://www.tomshardware.com/reviews/2d-windows-gdi,2547...

Aero was on for all Tests

5850 Stock

BENCHMARK: DIRECT DRAWING TO VISIBLE DEVICE

Text: 53419 chars/sec
Line: 73421 lines/sec
Polygon: 8760 polygons/sec
Rectangle: 7286 rects/sec
Arc/Ellipse: 17416 ellipses/sec
Blitting: 14979 operations/sec
Stretching: 496 operations/sec
Splines/Bézier: 35026 splines/sec
Score: 2257

BENCHMARK: DIB-BUFFER AND BLIT

Text: 37707 chars/sec
Line: 137363 lines/sec
Polygon: 21731 polygons/sec
Rectangle: 2461 rects/sec
Arc/Ellipse: 29412 ellipses/sec
Blitting: 9923 operations/sec
Stretching: 1019 operations/sec
Splines/Bézier: 36430 splines/sec
Score: 2695

5850 775/1125

BENCHMARK: DIRECT DRAWING TO VISIBLE DEVICE

Text: 52521 chars/sec
Line: 73421 lines/sec
Polygon: 9939 polygons/sec
Rectangle: 7819 rects/sec
Arc/Ellipse: 17325 ellipses/sec
Blitting: 15119 operations/sec
Stretching: 491 operations/sec
Splines/Bézier: 39078 splines/sec
Score: 2315

BENCHMARK: DIB-BUFFER AND BLIT

Text: 37707 chars/sec
Line: 137363 lines/sec
Polygon: 21731 polygons/sec
Rectangle: 2461 rects/sec
Arc/Ellipse: 29138 ellipses/sec
Blitting: 9923 operations/sec
Stretching: 1024 operations/sec
Splines/Bézier: 43917 splines/sec
Score: 2765
m
0
l
April 29, 2010 3:50:04 AM

Just install 10.4 and so far so good ,no craches in unigine heaven 2(27FPS averaeg) ,BFBC2(45fps aver.),FC2(small ranch 71fps av.)-All very high
m
0
l
April 29, 2010 7:03:04 AM

Annisman said:
Thanks Maziar, you're always on the ball when it comes to driver releases.

No problem :) 
As for links,all if them were working when i posted but when i checked again today,the first one didn't work but the other 3 worked
m
0
l
April 29, 2010 7:07:02 AM

EXT64 said:
Well, I'm fairly impressed. Compare these to the review. Some did not improve, but most were from good to amazing in my opinion!

Review: http://www.tomshardware.com/reviews/2d-windows-gdi,2547...

Aero was on for all Tests

5850 Stock

BENCHMARK: DIRECT DRAWING TO VISIBLE DEVICE

Text: 53419 chars/sec
Line: 73421 lines/sec
Polygon: 8760 polygons/sec
Rectangle: 7286 rects/sec
Arc/Ellipse: 17416 ellipses/sec
Blitting: 14979 operations/sec
Stretching: 496 operations/sec
Splines/Bézier: 35026 splines/sec
Score: 2257

BENCHMARK: DIB-BUFFER AND BLIT

Text: 37707 chars/sec
Line: 137363 lines/sec
Polygon: 21731 polygons/sec
Rectangle: 2461 rects/sec
Arc/Ellipse: 29412 ellipses/sec
Blitting: 9923 operations/sec
Stretching: 1019 operations/sec
Splines/Bézier: 36430 splines/sec
Score: 2695

5850 775/1125

BENCHMARK: DIRECT DRAWING TO VISIBLE DEVICE

Text: 52521 chars/sec
Line: 73421 lines/sec
Polygon: 9939 polygons/sec
Rectangle: 7819 rects/sec
Arc/Ellipse: 17325 ellipses/sec
Blitting: 15119 operations/sec
Stretching: 491 operations/sec
Splines/Bézier: 39078 splines/sec
Score: 2315

BENCHMARK: DIB-BUFFER AND BLIT

Text: 37707 chars/sec
Line: 137363 lines/sec
Polygon: 21731 polygons/sec
Rectangle: 2461 rects/sec
Arc/Ellipse: 29138 ellipses/sec
Blitting: 9923 operations/sec
Stretching: 1024 operations/sec
Splines/Bézier: 43917 splines/sec
Score: 2765

That's great.
Have you run in to any 2D problems(Horizontal lines in the screen etc)

EDIT,
I just installed it and currently i don't have any 2D problems,will report back after few days of testing.
With Catalyst 10.3,i had problems with Dirt2 in DX11 mode,it didn't detect CrossFire and my FPS was low but 10.4 fixed it and now i can run it fine on DX11 mode with CF detected.
So far,its been an excellent driver for me
m
0
l
April 29, 2010 12:26:00 PM

I think the Dirt 2 Intro movies still had horizontal lines (when unOC'ed, so I assume at 157/300), though I am not 100% sure. Could also just be a Dirt 2 glitch.

Maziar, in Dirt 2, do you get any flickering shadows on some objects? The track that is the worst for me is Utah (either direction).
m
0
l
April 29, 2010 1:16:52 PM

This is my experience: "Catalyst Install Manager has stopped working"

Problem signature:
Problem Event Name: APPCRASH
Application Name: InstallManagerApp.exe
Application Version: 3.0.769.0
Application Timestamp: 4bbbe6e7
Fault Module Name: MFC80U.DLL
Fault Module Version: 8.0.50727.1833
Fault Module Timestamp: 482bb4a2
Exception Code: c0000005
Exception Offset: 00000000000854ee
OS Version: 6.1.7600.2.0.0.256.48
Locale ID: 1033
Additional Information 1: 2a81
Additional Information 2: 2a81cbaea89bd5754e854ae615f08673
Additional Information 3: 434f
Additional Information 4: 434f7d79cfc042d09f75d7fc7f922c8b

I've tried installing it numerous times, even restarting my PC in between and I've checked that it is the correct 64bit driver for windows 7.
m
0
l
April 29, 2010 3:08:25 PM

EXT64 said:
I think the Dirt 2 Intro movies still had horizontal lines (when unOC'ed, so I assume at 157/300), though I am not 100% sure. Could also just be a Dirt 2 glitch.

Maziar, in Dirt 2, do you get any flickering shadows on some objects? The track that is the worst for me is Utah (either direction).

No it works fine for me,try running it in DX9 mode and see if it happens or not
m
0
l
April 29, 2010 3:08:36 PM

Gulli said:
This is my experience: "Catalyst Install Manager has stopped working"

Problem signature:
Problem Event Name: APPCRASH
Application Name: InstallManagerApp.exe
Application Version: 3.0.769.0
Application Timestamp: 4bbbe6e7
Fault Module Name: MFC80U.DLL
Fault Module Version: 8.0.50727.1833
Fault Module Timestamp: 482bb4a2
Exception Code: c0000005
Exception Offset: 00000000000854ee
OS Version: 6.1.7600.2.0.0.256.48
Locale ID: 1033
Additional Information 1: 2a81
Additional Information 2: 2a81cbaea89bd5754e854ae615f08673
Additional Information 3: 434f
Additional Information 4: 434f7d79cfc042d09f75d7fc7f922c8b

I've tried installing it numerous times, even restarting my PC in between and I've checked that it is the correct 64bit driver for windows 7.

Can you install older drivers ?
m
0
l
April 29, 2010 3:19:35 PM

Maziar said:
Can you install older drivers ?


Well, 10.1 through 10.3 never gave a problem, but now I can't install 10.3 either (it's still on my OS but and functioning, but when I download it from ATI's website the installer crashes as well). Could this have something to do with recent Windows 7 updates or something?
m
0
l
April 29, 2010 3:50:50 PM

Maybe.
You may want to do a fresh install of your OS
m
0
l
April 29, 2010 8:12:36 PM

Here are my Catalyst 10.4 results from that benchmark program. I don't have any previous scores to compare to though.


m
0
l
April 29, 2010 8:24:18 PM

I assume that is with Aero off? That is quite a bit below mine (several posts up, stock 5850). What score do you get with Aero?
m
0
l
April 29, 2010 8:50:10 PM

I'm getting massive shadow flickering in GTAIV. Only complaint.
m
0
l
April 29, 2010 10:09:48 PM

Wow wtf? I thought having Aero off was suppose to yield better performance with everything??? Guess not.....

Aero On, with everything checked under the "Advanced Settings" tab:



Aero On, with everything un-checked under the "Advanced Settings" tab:
m
0
l
April 29, 2010 10:29:02 PM

Yeah, doesn't make a whole ton of sense, but Aero does seem to help some, hurt others, or have no effect.
m
0
l
April 30, 2010 4:25:56 AM

Just installed my Asus 5850 and things seemed good with Cat 10.3 (was already on system), but after installing 10.4 I'm getting some wicked horizontal flickering on my secondary monitor.

My main display is a Samsung 24" (1920x1200) connected via the HDMI-DVI convertor and my secondary is a 19" Benq connected to the native DVI port.

Looks similar to this: http://www.youtube.com/watch?v=NL7GV1vzH1A&feature=play...
m
0
l
April 30, 2010 5:32:47 AM

Well my 5970 no longer crashes in 2D mode at standard clocks. I don't have to force higher idle clocks anymore which is a huge plus. Lower power and temperature during idle.

According to MSI afterburner my second GPU for the 5970 didn't even move during 2D tests so the performance any only mediocre. The 1st core didn't lift off 2D speeds so performance was like a 5850. Not that it matters since nothing 2D would require more power than that anyway but would have liked to see the benchmark soar with two fully active cores.
m
0
l
April 30, 2010 5:50:24 AM

I am having issues with 10.4, reverted back to 10.3 and everything went back to normal (well not normal but better).

And I am not doing a fresh OS install, if I didn't have to do it with my 260 I shouldn't have to do it with my 5850. BC2 crashes for no reason, lag lag lag in loading times.. Smart Doctor gives me some sort of .dll error...

IMO AMD drivers are inferior compared to NV's. I can't even play BC2 with v-sync enabled (stays disabled no matter what) ..Dirt2 has some weird glitching glitching going on. The only game that works properly is Warhead..

Bummer...
m
0
l
April 30, 2010 7:16:19 AM

10.4 just installed, everything was fine until i tried playing BC2. the loading times are still long, and my framerate has been destroyed. used to get about 70fps, and now get less than 20 at best. totally unplayable, very strange...
m
0
l
April 30, 2010 7:31:38 AM

rofl_my_waffle said:
Well my 5970 no longer crashes in 2D mode at standard clocks. I don't have to force higher idle clocks anymore which is a huge plus. Lower power and temperature during idle.

According to MSI afterburner my second GPU for the 5970 didn't even move during 2D tests so the performance any only mediocre. The 1st core didn't lift off 2D speeds so performance was like a 5850. Not that it matters since nothing 2D would require more power than that anyway but would have liked to see the benchmark soar with two fully active cores.

Well when i turned on my PC,i saw some horizontal lines(Although it was in 157/300) but they quickly disappeared.
However when i am in windows, it seems i no longer have to set the 2D clocks to 400/900,because it works seems its working fine in windows without any crashes
m
0
l
April 30, 2010 7:37:36 AM

welshmousepk said:
10.4 just installed, everything was fine until i tried playing BC2. the loading times are still long, and my framerate has been destroyed. used to get about 70fps, and now get less than 20 at best. totally unplayable, very strange...

Try doing a fresh install of 10.4(with driver sweeper and safe mode)
m
0
l
April 30, 2010 7:38:00 AM

seriously maziar, i know you need to keep the forum from getting cluttered but cannot not have my own thread to try and solve my problem?

i posted here because its a thread about experiences with the drivers, and is therefore relevant. I created my own thread so i could discuss my specific issue, which if done here would class as derailing.

it is incredibly unfair to close a persons thread before they can even discuss their issue, and i sure as hell don't think i should be discussing it here.
m
0
l
April 30, 2010 9:12:31 AM

The reason i locked that is because i know you will get answers here(because by making this topic i wanted users to post their experiences with it)but if you think you won't get your answer,then its OK,I'll re-open that for you but the reason of posting threads when a new driver comes out is to know the problems and overall experience of users with this and everyone who has a problem can ask here and it will be answered but since you think you won't,then check your thread,its opened now :) 
m
0
l
April 30, 2010 9:41:41 AM

@ Maziar
If i may i would like to offer some feed back to this issue,
I'm posting here as its where the issue is at (this time) and would welcome some forum response otherwise i would have done this as a PM. This isn't directed at you Maziar :)  and if you could would you post this to the other mods for their take on the suggestion, is there a Mods forum ?

If as seems the case these days that people are banned (sorry but that's what it comes down to) from having their own threads when new hardware/software launches then can we at least have subsections ? So we would have for example a Reviews and general discussions thread posted as a sticky as well as a Problem solving or technical issues thread. In my experience its very easy for a request for specific assistance to get lost in the sea of the new type review threads where there are often several different separate discussions/debates going on.

Thanks

Mactronix :) 
m
0
l
April 30, 2010 10:20:39 AM

I don't want to go off-topic here :)  check your PM's mac
m
0
l
April 30, 2010 11:51:08 AM

Well, I finally fixed almost all of my DiRT 2 problems...by forcing DX9.

My horizontal glitch bars in the intro movies -> Fixed
Glitching Shadows -> Fixed

Not really optimum though. But this likely has nothing really to do with drivers (9.12HF-Present does it, yet before the patch it did not). Something in my DiRT 2 DX11 path must have gotten messed up. I'll have to give some of those DX11 benches (like Unigine) to make sure it is not all DX11.
m
0
l
April 30, 2010 2:51:16 PM

I had problems with Dirt2 DX11 with older drivers but with this one they are gone.
however there are many users having problem with Dirt2 DX11 and forcing DX9 has helped.
Maybe a future patch will make things better
m
0
l
April 30, 2010 3:08:56 PM

Dirt2 DX11 worked fine for my 5750 as I just picked up Dirt2 last night on Steam for $9.99.
m
0
l
April 30, 2010 4:59:32 PM

my load times in bfbc2 have gone from 30-40 seconds, to about 5 seconds... getting 100fps constant too! Very good drivers, at least for me.
m
0
l
April 30, 2010 5:02:24 PM

My theory is that perhaps there was a mishap when Steam force updated my game. I should say though that the game still looked great and was very playable, it was just 3-5 tracks that had jittery shadows. I really want to try reinstalling the game, but I have the download only version and that will take a while.
m
0
l
April 30, 2010 6:20:08 PM

BIG Cursor is back - at least for me with 10.4

Could be related to enabling hardware acceleration to flash. At least now when hardware acceleration on flash is enabled and viewing in full screen mode no more driver crashes.

m
0
l
April 30, 2010 9:02:42 PM

Haven't had Big cursor problem yet.
I'll post if i run in to it
m
0
l
April 30, 2010 9:23:40 PM

Well, Unigine 2.0 worked and looked great, so my problem is purely a DiRT 2 or DiRT 2 corruption problem.
m
0
l
April 30, 2010 9:47:38 PM

Although you mentioned it takes time but i think reinstalling the game may help
m
0
l
April 30, 2010 10:03:51 PM

Yeah, I'm definitely going to give it a try very soon as I have much faster internet here at college than at home. However, 15GB still takes a decent bit of time.
m
0
l
!