Sign in with
Sign up | Sign in
Your question

Having a really hard time getting SATA to run through AHCI

Last response: in Storage
Share
July 22, 2012 10:23:54 PM

Hello, I've been trying to get my SATA to run through AHCI and have been failing miserably. I'm not even quite sure what it means to have it on AHCI, but from what I understand it is faster. Seeing as I've spent quite a bit of money on all new computer parts for my first build, I would like for it to run top notch.

I've already tried changing to AHCI mode in the BIOS and the computer fails to start when I do this.

I then tried installing the drivers for AHCI from the internet which failed as well, prompting a message that claimed I did not meet the system requirements. I read the system requirements and I would have to think that the only one that I wouldn't likely meet would may be the last requirement which states... "The intel chipset software installation utility must be installed prior to installing Intel (R) Rapid Storage Technology"

I've now accepted that I don't really know what I am doing and am now seeking help.

Here's my set up

SSD: Plextor M3 Series PX-256M3 2.5" 256GB SATA III Internal Solid State Drive (SSD)

Mobo: ASUS P8H77-V LE LGA 1155 Intel H77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard

Processor: Intel Core i5-2500K Sandy Bridge 3.3GHz (3.7GHz Turbo Boost) LGA 1155 95W Quad-Core Desktop Processor Intel HD Graphics 3000 BX80623I52500K

Video Card: EVGA 012-P3-1570-AR GeForce GTX 570 (Fermi) 1280MB 320-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card

RAM: CORSAIR Vengeance 12GB (3 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model CMZ12GX3M3A1600C9

Power Supply: COOLER MASTER Silent Pro M700 RS-700-AMBA-D3 700W ATX12V V2.3 SLI Certified CrossFire Ready 80 PLUS BRONZE Certified Modular ...

Optical Drive (not sure if this matters): ASUS DRW-24B1ST/BLK/B/AS Black SATA 24X DVD Burner - Bulk - OEM
July 23, 2012 1:34:30 AM

Found my answer right here in the forums actually. Here's the link just in case anyone else was having the same problem as I.

support.microsoft.com/kb/922976
m
0
l
a c 379 G Storage
July 23, 2012 12:05:22 PM

The bios has to be set to AHCI prior to installing the OS. Making changes to AHCI after installing the OS will cause the problem you were having. During windows installation, it examines your hardware and bios settings and install drivers accordingly. Since you didn't initially have AHCI turned on in the bios, the drivers didn't get installed.

Good job on researching your problem and figuring it out yourself.
m
0
l
!