Second LAN card not working on Redhat AS 4 machine.

My first LAN card, VIA Technologies(its inbuilt on motherboard) is working fine, howver the other lan card , Realtek PCI card is not working at all though i have configured it the same way i did it for eth0.

Its driver was automatically detected and installed by OS and also i can configure it under /root/sysconfig/network-script/ifcfg-eth1


# vi ifcfg-eth1
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
ONBOOT=no
USERCTL=no
IPV6INIT=no
PEERDNS=yes
GATEWAY=10.55.10.1
TYPE=Ethernet
DEVICE=eth1
HWADDR=00:50:ba:d9:5b:ff
BOOTPROTO=none
NETMASK=255.255.255.0
IPADDR=10.55.10.12

After configuration i can see both the device in ifconfig.

# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0E:A6:C9:BD:2B
inet addr:172.28.89.191 Bcast:172.28.255.255 Mask:255.255.0.0
inet6 addr: fe80::20e:a6ff:fec9:bd2b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1303 errors:0 dropped:0 overruns:0 frame:0
TX packets:438 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:114034 (111.3 KiB) TX bytes:60823 (59.3 KiB)
Interrupt:201 Base address:0x6000

eth1 Link encap:Ethernet HWaddr 00:50:BA:D9:5B:FF
inet addr:10.55.10.12 Bcast:10.55.10.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:169 Base address:0xd000

I even tried swapping the IP address setting but in each case Realtek is not working, also it is old card so it might be faulty, but how can i confirm?
5 answers Last reply
More about second card working redhat machine
  1. What are you trying to do with the second LAN card? Have you configured your firewall to allow this second LAN to access the network via ETH0? Keep in mind ETH1 is not on the same network as ETH0 as you have it currently configured.

    Regarding the "old" Realtek card, what driver did RH install for it?
  2. I want to use both network 10.55.10.0/24 as well 172.28.89.0/24 network simulataneoulst on one system. As i mentioned in my first post i have tried swapping the IP address on both cards, eth0 works fine with both networks but eth1(Realtek) doesnt. So this confirms no Firewall, router ACL etc blocks my access.

    Also, i am not sure how to check the driver details, here's /etc/modprobe.conf info.

    # cat /etc/modprobe.conf
    alias snd-card-0 snd-via82xx
    options snd-card-0 index=0
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
    remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx
    alias usb-controller ehci-hcd
    alias usb-controller1 uhci-hcd
    alias eth0 via-rhine
    alias eth1 8139too
  3. First, lets verify that the Realtek actually works. Look at the card and your switch to see if the link lights on on and whether the traffic indicator shows anything. If still not sure after doing that, switch to a known good cable and try again.

    If still no luck, you will need to restart the system and then enter the BIOS and disable the on-board VIA ethernet adapter. The intent is to make the Reaktek eth0 to see if it can be installed and will connect to your primary network. If it doesn't work, that card is likely defective.

    If it does work, then you have a configuration issue. Please describe what you are trying to do with the 2 networks. Are you planning to use both networks on just the one computer or are you acting as a bridge to establish a separate LAN segment (your system as the bridge/firewall) for other users (what Windows would call Internet Connection Sharing)?
  4. Lights are not properly blinking on Realtek, i tried disabling onboard LAN but no hope, so i think there is some problem with the card itself. I ll get it replaced, thnx.
  5. Definitely sounds like the Realtek is defective. Good luck!
Ask a new question

Read More

NICs LAN Components