Solved

I can't get my SSD ACHI to quad boot

Hello, I bought a Crucial M4 256gb not too long ago. I followed instructions and I unplugged all the other 3 IDE drives in my PC and set my bios to AHCI in order to install win 7 properly.

The problem is that before I got the SSD my machine was set up as multi boot. Two HDDs have win 7 64 bits; one is SATA III and the other one is IDE, the 3rd SATA II drive has Ubuntu 64bits. The Ubuntu drive was set as active and I would boot from GRUB and select between ubuntu or 2 Win 7 installations. Now that my ssd is running I have lost the ability to multi boot.

I tried using EasyBCD 2.1.2, which is compatible with GRUB, to set up a quad boot system. I am only able to get the program to recognize the other 2 windows 7 installations but I can't load the OSes because the ACHI drivers are not installed on the Sata and IDE drives.

I cant get Easybsd to recognize my ubuntu install. The only way I can get the ubuntu drive to boot is from the bios boot menu but once again the system does load because I don't have the ACHI drives on it either.

I would like to be able to set up a quad boot system without having to re install all any of my OSes. I am specially interested in getting my Ubuntu drive back in order. I am sure it is possible.

Thank you in advance for your help.
5 answers Last reply Best Answer
More about achi quad boot
  1. Best answer
    Insert your Ubuntu CD, reboot your computer and set it to boot from CD in the BIOS and boot into a live session. You can also use a LiveUSB if you have created one in the past.
    Install and run Boot-Repair

    Click "Recommended Repair".
    Now reboot your system. The usual GRUB boot menu should appear. If it does not, hold Left Shift while booting. You will be able to choose between Ubuntu and Windows.
  2. Ok I did as you said and now I am able to dualboot in windows and ubuntu. That is good enough for me.

    However, every time I try to boot into ubuntu I get stopped midway with the following message:
    error while mounting /media/sdc1 press S to skip or M for maintenance. I press S and the systems loads normally and all drives are recognized. I partitioned my ubuntu drive into /, /home and /swap. Strangely enough when I open GPARTED it shows that I have 4 Partitions in my ubuntu drive: /dev/sdc1 (home) dev/sdc3(/) /dev/sdc2 (extended) and /dev/sdc5(linux-swap) which is a subdirectory of sdc2.

    What can I do in order to prevent that annoying mounting error from happening again?

    By the way, here is the output from boot repair with detailed info of my hard drives and partitions. I hope it is helpful:

    http://paste.ubuntu.com/1107386/

    Edit: I have noticed that the swap partition isn't active either. I have to do "Swapon" on the swap partition in order to active my swap. I tried to delete the extended partition and recreate the swap partition again, but it is still set to inactive after reboot and the error message while booting ubuntu has not change either.
  3. Try editing your /etc/fstab file and commenting out the line with /media/sdc1

    sudo vi /etc/fstab
  4. Ok I edited my fstab file and the mounting error is gone. Could you tell me how was this error caused?

    Also, I got the following message regarding my swap partition. Swap is still set as inactive from the get go:

    E325: ATTENTION
    Found a swap file by the name "/etc/.fstab.swp"
    owned by: root dated: Tue Jul 24 01:32:10 2012
    file name: /etc/fstab
    modified: YES
    user name: root host name: sugetsu-desktop
    process ID: 4547
    While opening file "/etc/fstab"
    dated: Thu Jul 5 19:49:07 2012

    (1) Another program may be editing the same file. If this is the case,
    be careful not to end up with two different instances of the same
    file when making changes. Quit, or continue with caution.
    (2) An edit session for this file crashed.
    If this is the case, use ":recover" or "vim -r /etc/fstab"
    to recover the changes (see ":help recovery").
    If you did this already, delete the swap file "/etc/.fstab.swp"
    to avoid this message.
  5. Best answer selected by sugetsu.
Ask a new question

Read More

SSD Boot Ubuntu Storage