Sign in with
Sign up | Sign in
Your question

Sound and optical drive faulty (P5KPL-CM)

Last response: in Motherboards
Share
February 25, 2011 10:07:01 PM

Hello good people, I have an issue that has left me stumped and now I hope that maybe you can give me some pointers,

The sound isn't working on my computer and the same thing goes for my optical drive, including my virtual ones. When I check the device manager they show up, with the warning sign in front of them indicating that they're faulty.

So far, I've tried downloading new sound drivers and chip-set from Asus' homepage. I've also tried uninstalling the units in the hope of plug 'n play sorting things out. I've checked inside the chassis for loose wires and cleaned it from (substantial amounts of) dust as well as run the FixIt utilities from Microsoft. I've also scanned the computer for malware with a couple of different programs, just in case (shows how much I know about these things I guess....). No luck so far and that's how far I think I'm going to get on my own.

My motherboard is the Asus P5KPL-CM
My OS is Windows XP SP3
The optical drive is a TSSTcorp SH-S223F

Grateful and appreciative of any help and tips I can get.
a b Ĉ ASUS
a c 108 V Motherboard
February 25, 2011 11:41:34 PM

Welcome to the forums, Newcomer! Check this out:

http://www.guru3d.com/category/driversweeper/

Edit: After using driver sweeper, download and install the latest audio driver for your device.

February 26, 2011 6:13:37 AM

T_T said:
Welcome to the forums, Newcomer! Check this out:

http://www.guru3d.com/category/driversweeper/

Edit: After using driver sweeper, download and install the latest audio driver for your device.



Thanks for the tip and the welcome, I'm also starting to lean that there's something wrong in the registry, old drivers or such.

Following the link though, the driver sweeper is aimed at Creative and Realtek for sound and Nvidia for chip set. I have VIA HD Audio for sound and the chip set I believe is Asus' own(?). Worth a try anyway?
Related resources
February 26, 2011 7:02:31 AM

I downloaded the latest version of Driver Sweeper and found a Creative sound driver which I deleted and the installed the latest driver that I found at Asus' homepage. No dice so far.

All the faulty units show a Code 39 error in the device manager and I just noticed that the Plug and Play Software Device Enumerator also shows this error message. Could this cause the problems and if so, how can I fix it?
March 20, 2011 10:03:47 AM

Hello again. I've hardly been home the past couple of weeks, so haven't bothered too much with the computer until now.

Things have improved, somewhat. After a system restore as well as following the advice found in this thread and a few other places, my optical drive is now working correctly. The Software Device Enumerator also appears to be working.

As far as the sound goes though, still no dice. The difference this time is that it shows up in the unit/device manager as working correctly, but VIA HD Audio Deck won't run and when I open Sound and Sound units (devices? not sure what it is in the English version), it tells me that no sound devices were detected.

This is actually more frustrating, since before at least both I and the computer agreed that things weren't working the way they should. ;) 

EDIT: I'm also aware that this might mean that it isn't a motherboard issue, maybe the topic should be moved?

EDIT2: Nevermind, it's working now. For some reason, one of the fixes I've tried before decided to suddenly work now. All is good. Thanks for all the help.
!