Sign in with
Sign up | Sign in
Your question

Problem switching over to AHCI from IDE

Last response: in Storage
Share
July 24, 2012 12:37:57 PM

I apologize if this is in the wrong subforum. I wasn't sure whether to put it in storage or chipsets.

I installed Windows 7 quite awhile ago with all of my sata drives still running in IDE mode, because I hadn't realized that they were set to that by default. I've been trying to switch my drives over to AHCI without having to reinstall windows, but I'm running into a bit of a problem. I've already done the registry hack outlined here to enable the ahci drivers, but every time I try and reboot in order to switch my drives over to AHCI in the bios, I'm met with the message "Reboot and select proper boot device" when I hit save changes and try and boot into windows.

I've got an Asus Crosshair IV Formula board that I'm using. I've checked multiple times, and my drives are still set in the proper boot order and everything. Also, I've noticed that even when I have AHCI set in the bios, the bios still seems to autodetect the drives as IDE anyways; they show up in the bios menus labelled as IDE, at least. Any help would be much appreciated, as I've been trying to figure this one out on my own for awhile.
July 24, 2012 2:01:54 PM

Nevermind. After going through my drives one by one starting with my boot drive, I seem to have solved my problem. AHCI is working fine now.
m
0
l
!