Sign in with
Sign up | Sign in
Your question

OCZ Vertex 2 SSD not working

Last response: in Storage
Share
July 25, 2012 1:18:30 PM

I've recently bought an OCZ Vertex 2 SSD 128 GB used from a guy on the Overclockers members market that was used. I've plugged it into my machine and it isn't being detected at all. I've tried different SATA ports, and tried taking the SATA cable and Power cable out of my 3TB Storage HDD and using them for my SSD, but it still isn't working. BIOS, device manager and device management do not detect it. My system specs are as follows:

MSI 770-G45 Motherboard
AMD Phenom II x4 955 CPU @ 3.6 GHz
8GB DDR3 RAM
Windows 7 64-bit

I have 3 hard drives including the SSD - a 500GB with windows on and a 3TB for storage, and 1 disk drive. I'm assuming this means the SSD is broke? Or is there anything anyone can suggest?

More about : ocz vertex ssd working

a c 180 G Storage
July 25, 2012 1:19:43 PM

Return it and get your money back.
July 25, 2012 1:37:09 PM

So the drive is definitely broke then? Guess i'll have to hope that i get my money back off the guy then. From what i remember he's only had it 6-8 months, and according to the warranty info leaflet it's covered for 3years, but he didn't send me proof of purchase so it's not like i can send it back to OCZ either :/ 
Related resources
July 31, 2012 2:54:20 PM

drive works fine in another system :kaola: 
a c 283 G Storage
July 31, 2012 3:00:59 PM

I notice you have an MSI motherboard. Check you motherboard System BIOS. In some BIOS versions used by MSI you need to go to a section of the BIOS where you can enable drives. Once you enable a drive you can then go to another section and select the ssd as the primary boot drive.
July 31, 2012 3:14:23 PM

Thanks for the replies. Supermozz is the guy i bought the drive from, and as he said the drive works fine when he tested it on his pc's, so he's going to send it back to me and hopefully i can get it working. I have never updated my BIOS / firmware on my motherboard so I am going to try that first, I'll post back with results after I've tried it with the SSD.
!