Sign in with
Sign up | Sign in
Your question

Catalyst 10.4, BC2 runs like crap.

Tags:
  • Radeon
  • Games
  • Catalyst
  • Graphics
Last response: in Graphics & Displays
Share
April 30, 2010 7:14:07 AM

Hey guys,

so i've just fired up battlefield BC2 for the first time since installing cat 10.4 drivers and for some reason the game is running like crap.

whereas before i would get about 70fps, i now get about 15. totally unplayable. ive googled, but it seems this issue is not widespread. has anyone else encountered this?

i guess i will just avoid the game til the next driver update, but it seems a little weird. no biggie, i barely play it anymore anyway, i just felt like a quick game and was horrified at the performance...

More about : catalyst bc2 runs crap

April 30, 2010 12:23:15 PM

Have you tried Maziar's suggestion yet?
m
0
l
April 30, 2010 2:11:33 PM

I think this driver is just buggy full stop. People have been getting all sorts of issues with them.
Im glad i decided not to bother and would recomend that others who dont want the hastle of potentially cocking up a perfectly adequatly performing system to give them a swerve as well.
If its just the one game and you dont play it that much then no biggie i guess. Personaly i would go back to the 10.3 drivers.

Mactronix
m
0
l
Related resources
April 30, 2010 2:50:45 PM

WR2 said:
Have you tried Maziar's suggestion yet?

Which is doing a clean install
m
0
l
Anonymous
April 30, 2010 5:20:26 PM

Hello.....

first you try to decrease the desktop resolution(dont'ask me why?)
if still game runs same reinstall the older ones for temporary gaming so u wont have to wait, but the best idea will be the
update of the drivers,or try reinstalling the same.If it doesnt work contact....

best of luck comrade..........

CHARGE>>>>>>
m
0
l
April 30, 2010 9:10:43 PM

I'd say do two things. First, delete all ATI software and drivers, then reinstall the newest versions. Second, make sure you do not install Hydravision. Otherwise... well who knows.
m
0
l
April 30, 2010 10:30:11 PM

thanks for the suggestions guys (and maz for re opening the thread :p ), a normal re-install/repair didn't work, so i did a clean uninstall then re-installed the driver.
the problem seems mostly gone. my framerate is back up to playable levels, though is still lower than it was before. im now getting about 60fps.

my load times are still ultra long though, so that issue doesn't seem to have been fixed for me. slightly confused now...
m
0
l
April 30, 2010 11:10:02 PM

welshmousepk said:
thanks for the suggestions guys (and maz for re opening the thread :p ), a normal re-install/repair didn't work, so i did a clean uninstall then re-installed the driver.
the problem seems mostly[i/i] gone. my framerate is back up to playable levels, though is still lower than it was before. im now getting about 60fps.

my load times are still ultra long though, so that issue doesn't seem to have been fixed for me. slightly confused now...


My loads still the same(over 40 seconds),FPS increase few frames and u can Tab out,but as soon as i enable ATI Overdrive ,crash will follow sooner or later.Reinstalled (cleen,driver sweeper,etc.) twice.

I love uuuuuuuuuuuuu......ATI!!!!!!!!!!
m
0
l
May 1, 2010 9:44:04 AM

welshmousepk said:
thanks for the suggestions guys (and maz for re opening the thread :p ), a normal re-install/repair didn't work, so i did a clean uninstall then re-installed the driver.
the problem seems mostly gone. my framerate is back up to playable levels, though is still lower than it was before. im now getting about 60fps.

my load times are still ultra long though, so that issue doesn't seem to have been fixed for me. slightly confused now...

Have you tried re-installing the game too ?
Also check your PM's
m
0
l
May 2, 2010 2:00:19 AM

cant really reinstall the game maz, as i have the steam version. re-installing would require deleting and re-downloading it. slow speeds and Download caps make that a last resort, right now im fine with just putting up with the load times.

not sure why some people are getting the decreased load times and other's aren't though.
m
0
l
May 2, 2010 2:37:47 AM

if you have an external HDD, you can make a backup copy of the game to re-install from (i keep all of my steam games backed up on my server so when i need to re-install i don't have to re-install them)

i'm happy about the 10.4's, really helped load times (it was like 35-40s with CF4870 1GB)
m
0
l
May 2, 2010 7:01:33 AM

welshmousepk said:
cant really reinstall the game maz, as i have the steam version. re-installing would require deleting and re-downloading it. slow speeds and Download caps make that a last resort, right now im fine with just putting up with the load times.

not sure why some people are getting the decreased load times and other's aren't though.

Try this
http://support.amd.com/us/kbarticles/Pages/ATI-Catalyst...
m
0
l
May 2, 2010 9:23:56 PM

Ehh I like Steam for the convenience and sale prices, but yea I prefer having a real copy any day.
m
0
l
May 3, 2010 3:13:43 AM

wolfram23 said:
Ehh I like Steam for the convenience and sale prices, but yea I prefer having a real copy any day.


i don't in the slightest.

most games these days don't even come with manuals, its just a disk in a case. i can burn my downloaded steam games to a dvd and have that myself. and once i've bought a game on steam, i own it forever. if i lose the disk, my pc fails and i lose all the data, i move to another country or any other strange circumstance, i can just re-download my games at any time.

now im not a huge fan of the steam software, but isure as hell would rather deal with it than a video game store. steam will even refund me if the game doesn't work, try getting EBgames to do that...
m
0
l
May 3, 2010 3:30:41 AM

I think the true brilliance of Steam is for older games. Try finding an old game like Jedi Knight x, etc., in a store new. No chance, but on steam it is <$10. For newer games, I'm not a huge fan of downloading 10-15GB, so I'd prefer the CD, but it isn't a huge issue normally.
m
0
l
!