Sign in with
Sign up | Sign in
Your question

External hard disks don't spin down in Windows 7

Last response: in Storage
Share
July 26, 2012 9:47:04 AM

Hi all,

I would like to know if there's a way to force my external hard drives even if I haven't ejected them. I know this happened in my previous XP system. If I wanted to use them, I had to wait for them to spin up. Now, in Windows 7 they never spin down and while it is convenient that they're always ready to use, one of them (a WD Elements) is running hot (49 degrees Celsius, according to Hardware Monitor - I live in a very hot place) and they keep using power I don't want them to use.

I looked up the problem online and all I could find was people complaining that they don't spin down AFTER they've ejected them. This is not what I want. I want them to go to sleep mode or something while they're still shown (like it was in Windows XP). I love my new PC, but this is a bit annoying and makes me spend electricity I shouldn't spend.
a c 215 $ Windows 7
a c 354 G Storage
July 26, 2012 12:05:35 PM

Have you gone into the advanced power settings? There is a setting to "spin drives down after xxx minutes". If this doesn't work, your external enclosure may be overriding this setting.
July 26, 2012 12:18:24 PM

I have been to those setting and I have set the hard drives to spin down after 20 minutes. But this is related to whether I am using the pc or not. It is not related to whether this particular drive is being used (same timer with the screensaver - or so I guess). I haven't used that drive today and yet it is still spinning.
a c 215 $ Windows 7
a c 354 G Storage
July 26, 2012 12:25:42 PM

It sounds like the external enclosure is not passing the the spin down command to the drive.

HDDScan might be able to resolve it. It has power management features.

http://hddscan.com/
!