Lan driver missing

Hello, I recently made a fresh install of Windows XP home version and installed the drivers after the process was over (YES I installed the chipset first, and then the graphics thing, followed by the audio driver). The problem is that my laptop, an acer AOA150 (a netbook) does not connect to the internet. I installed the respective drivers for lan and WLan from the acer website and installed them. When I try to connect to a WI-Fi, or even via DSL, I get full signal, it tells me i'm connected but i can't access to the internet. I also went to the Device Manager tool and there's a yellow "?" right next to the Ethernet drivers section. This is after I installed all the drivers. Please, I've tried everything and nothing works. And since i have no connection I can go to internet to download any drivers, I'm passing everything via USB. Thanks :)
20 answers Last reply
More about driver missing
  1. Hello and welcome to Tom's Hardware Forums.

    If you're sure the wireless is working, concentrate on that first because when that can go online, you can let the system search for the correct ethernet driver. Meanwhile, uninstall the driver that's in there at the moment.

    The wireless connectivity problem may be down to settings issues. Have you set the network up using the right information?
  2. Well, i've checked several times to see if the ip and dns settings are set to automatic, but still no access. Again, i have connectivity, but no access to internet. Thanks
  3. If you know the Default Gateway of the router and can access the settings, it's worth allocating an IP address manually. If the gateway is 192.168.0.1 for example, use the address 192.168.0.100. The subnet will set itself and the 0.1 address goes in the gateway box and the DNS box below that. If that doesn't force access. What shows up under the wireless connection when you run ipconfig /all from a command prompt?
  4. Now for a separate post just to kickstart the ethernet connection.

    You need to go into Control Panel>System>Hardware>Device Manager and scroll to Network Adapters, then right click ethernet go to Properties and then click the Details tab. Scroll to HardwareIDs and take a note of the four characters which follow VEN for Vendor and also the four following DEV for Device.

    On your other machine, go to http://www.pcidatabase.com and input those characters in the two relevant boxes and follow the trail to the right driver. When you find the list of the Vendor's drivers, they aren't in order so use your browser's Find facility to track the Device details. With luck you'll have an executable file but some will be a zipped folder. Either way, transfer it over and install it. It will be interesting to see if a wired connection can work.
  5. Ok, I was able to finally install the Ethernet drivers and getting them to work but I still have no connection. I went to the console and when i type ipconfig /all this is what i get:

    Host name:---
    Primary DNS suffix:
    Node type: unknown
    Ip routing enabled.... No
    WINS proxy enabled.... No


    Ethernet Adapted Local Area Connection 2:

    Media State: Media disconnected
    Description: Qualcomm Atheros AR8132 PCI-E Fast Ethernet Controller
    Physical Adress.... 00-23-5A-ED-DF-30

    Ethernet adaper wireless network connection 4:

    Connection-specific DNS suffix:
    Description: Atheros AR5006X Wireless network adapter
    Physical adress: 00-25-56-0D-64-A0
    DHCP enabled..... No
    IP adress.... 192.168.1.100
    Subnet Mask.... 255.255.255.0
    Default Gateway... 192.168.1.1
    Dns servers... 192.168.1.1

    Again, it says i have connection, even via cable (Which now works correctly) but i have no access still. Thanks.
  6. All the settings seem to be right except lack of a Leaase and the ethernet wired line - is the cable plugged in at both ends? Does the router have a small LED marked DSL and, if so, is it lit up? If you go into the router's settings by typing 192.168.1.1 into the URL address bar of Internet Explorer, do those settings show it to be connected to the Net?
  7. Yes, the cable is connected a both ends and when i go to my router settings it says that i have access but i cant surf on my pc.
  8. netorincon said:
    Yes, the cable is connected a both ends and when i go to my router settings it says that i have access but i cant surf on my pc.


    Can you please double check in Internet Explorer>Tools menu>Connection tab>LAN button that there are no ticks in the Proxy section and there is one in "Automatically Detect Settings.
  9. Yes, I just checked and the settings are just like you say... Nothing happens
  10. Any other ideas? Please I really need to get this pc working.
  11. Even though the ticks aren't showing for Proxy settings, it's still possible for the Registry to have it set differently and that could be why you seeing an unknown node type. If you're comfortable in the Registry, open it up by typing regedit in a Run box and press Enter.

    From the File menu, choose Export then note the name and location of the backup it is making in case you need it later. Navigate to this key
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters\
    and change the value of the EnableProxy to 0 or 1. Leave the Registry from the File menu and restart the system - twice. Does that help?
  12. Hmm, I went to the registry, but there's no such value under that key. Do I have to create it?
  13. netorincon said:
    Hmm, I went to the registry, but there's no such value under that key. Do I have to create it?



    Sorry - I missed your response. It's worth a try.
  14. I tried but idk what type should the new value be?
  15. Try a zero first but backup the Registry or at least that key before you write to it. The Export option form the File menu will do it for you.
  16. My best idea was to delete your posts on grounds of commercial Spamming, if having a username of twelve random characters wouldn't have been enough reason. If you have a genuine problem, post back with a little more detail, remove three of your links and you may get a serious response.
  17. I suppose that answer was for another thread? But tried with both 0 and 1 and didn't work
    OH and if I righ click the little connection icon and then go to status, it says that I'm not receiving any packets. Is this normal?
  18. First, try typing these two at a Command Prompt, one at a time of course:-
    ipconfig /flushdns
    and press Enter then
    netsh winsock reset catalog
    and press Enter again.

    Restart as requested and if that didn't fix it, delete the connection in Control Panel>Network Connections and uninstall the device in Control Panel>System>Hardware?Device Manager>Network Adapters and restart to let the system create a new connection after finding a driver for the device.
  19. Hey, guess what, I came up with the solution...

    I tried ot google that "not receiving packets problem" and one forum said that I should try to remove the WPA2 security from my router and see if I could connect after doing so. I did it, AND IT WORKED. I figured that my router was set to the highest speed (150mbps) and reduced that speed to 54mbps (which I don't even reach anyway), set the security encription to WEP and set my password again. Then I went to the pc to check if I had access, which I have now. I guess you were right in the beginning about it being something on my router but I never imagined that it'd be the password encryption, I thought it was something like my router not assigning an ip adress or something.

    Anyway, thank You very much for the time spent on trying to solve my problem, I appreciate it.

    *Edit*
    OH, and I had to re-reinstal xp just to make sure it wasn't a problem with my drivers, and to ensure a fresh OS with no modifications even though I could've skipped that step, I just wanted to be 100% sure.
  20. It matters not how you fixed it - YOU FIXED IT!!! :D
Ask a new question

Read More

Drivers Connection Windows XP