Sign in with
Sign up | Sign in
Your question

Question about Dual Channel

Last response: in Memory
Share
March 2, 2011 6:02:39 AM

Mobo: ASRock 870 Extreme3
RAM: GSkill Ripjaw (2x2GB) 1333 F3-10666CL8D-4GBRM

Mobo Manual: ftp://174.142.97.10/manual/870%20Extreme3.pdf

According to the manual, to enable Dual Channel, they need to both be in the blue slots (A1,B1).
When placed in both blue (A1,B1), no boot, no video.
When placed in both white (A2.B2) no boot, no video.
When placed in Blue/White (A1,A2) successful boot.

Is it Dual Channel mode when in A1/A2 or not? If not, is it a bad motherboard or is there some other trick?
I know I need to set the timing, but if I can't get video or past POST in order to set timings when in A1/B1.

D3: If memory sizing module not executed, start memory refresh and do memory sizing in Bootblock code. Do additional chipset intialization. Re-enable CACHE. Verify that flat mode is enabled.

More about : question dual channel

a b } Memory
March 2, 2011 2:35:15 PM

(1) If memory in A1/A2, should be in single channel mode. You can conferm this by downloading CPUID CPU-Z and runing it.

(2) First, I would download the ISO for Memtest86 and create a bootable CD. Run Memtest 86 on one module (in A1) slot, then try 2nd module in A1 slot.
2nd - If mem passes, then try one (or both) sticks in B1 slot (may need to check if system SHOULD boot with only one module in B1 slot.

You might try puting just the one mem module in A1. Go into bios and tell it to use profile 1. Then try with both A1/B1 poulated.

If both memory modules pass memtest, Using slot A1, I would suspect a MB issue.
March 2, 2011 3:08:53 PM

I was looking in the BIOS for the timings...and it looks intimidating.

Could someone walk me through it so I don't mess it up?

EDIT:
A1/A2 combo is single channel :( 
Related resources
a b } Memory
March 2, 2011 4:04:33 PM

First, I'm a Gigabyte/Intel fan. Have NO experience with Asrock MB/Bios.

Basically - ONly verify/set Dimm voltage to 1.5 V
(2) only set the first 4 parameters in memory (8,8,8,24), leaving others on auto.
(3) use defalut setting of Unganged.

I see nothing in the manual on beeing able to set XMP to use profile 1. This is where the bios reads what is stored on the memory module to Profile 1). There are normally several sets of settings in the memory modules - You can view them using CPUID-CPU-Z.

Hopefully one of the AMD/Asrock fans can help you out more!!
March 2, 2011 9:48:34 PM

RetiredChief said:
First, I'm a Gigabyte/Intel fan. Have NO experience with Asrock MB/Bios.

Basically - ONly verify/set Dimm voltage to 1.5 V
(2) only set the first 4 parameters in memory (8,8,8,24), leaving others on auto.
(3) use defalut setting of Unganged.

I see nothing in the manual on beeing able to set XMP to use profile 1. This is where the bios reads what is stored on the memory module to Profile 1). There are normally several sets of settings in the memory modules - You can view them using CPUID-CPU-Z.

Hopefully one of the AMD/Asrock fans can help you out more!!


I'm going to assume the following is what I need to change, but asking before I go ahead and make the change.

Memory Controller Unganged
Power Down Enabled Disabled What's this?
Bank Interleaving Auto What's this?
Channel Interleaving HASH2 What's this?

CAS Latency (CL) 9 Auto
TRCD 9 Auto
TRP 9 Auto
TRAS 24 Auto
March 2, 2011 10:37:28 PM

are you sure it's not the CPU's memory controller?

The dual channel memory should be recognized by both the motherboard AND the CPU. You should take the above advice first and check that each stick is working properly by running memtest86. If that does work then your ram should be fine and it's between the CPU and Mobo.

You may want to run a prime95 on your CPU to check whether the memory controller is working or not. But frankly, i'm not sure prime95 can even check that.

EDIT: try changing the unganged to ganged. Shut down the PC and then boot with the ram in the proper dual channel positions. It seems the ganged v unganged may be causing your problem.
March 2, 2011 10:42:02 PM

Should I still run prime95? Sounds like it might be a moot point in running it if it can't check the memory controller
March 2, 2011 10:58:38 PM

Change your settings in the BIOS from unganged > ganged. Do this with single channel mode that's been working. After you have it changed, turn the PC off, put the ram in the proper dual channel slots and boot it up. If this doesn't work then yea, i'd run prime95 on the sticks and see if they're the culprit.
March 2, 2011 11:25:37 PM

Should I change the BIOS memory timings as well?

According to the GSkill website seems that they highly recommend doing so to match the sticks.

Do I just do the 4 items above or are there any other settings I need to change?
March 2, 2011 11:38:16 PM

Well, first and foremost you should get them working in Dual channel (probably by changing from unganged > ganged) before you start working with the timings. You should, though, set the DRAM voltage to 1.5v. Once you have that accomplished then you can fiddle with the timings.
March 2, 2011 11:42:40 PM

My motherboard won't let me choose 1.5v, the closest match is 1.547v
March 2, 2011 11:46:16 PM

Have you flashed the bios?

The newest BIOS update should allow everything from 1.48v to upwards of 2.0v.

can you take pictures and show me where you're setting the voltage? also, are your sticks running in dual channel now?
March 2, 2011 11:47:38 PM

Haven't updated the BIOS. How do I take pictures of my BIOS?

No, haven't opened the case yet. Still single channel.
March 2, 2011 11:50:52 PM

Change unganged > ganged in the bios first. Shut down the PC and put the sticks into the corresponding dual channel slots then boot up.
March 2, 2011 11:52:50 PM

Alright, will do so now.
Will report when I get back.
March 3, 2011 12:04:07 AM

When both in blue slot I don't get video or POST beeps
When in one blue, one white, I get the usual one beep and it boots up.

These are the codes I get along with their meanings.
D1 - Perform keyboard controller BAT test. Check if waking up from power management suspend state. Save power-on CPUID value in scratch CMOS.

D3 - If memory sizing module not executed, start memory refresh and do memory sizing in Bootblock code. Do additional chipset intialization. Re-enable CACHE. Verify that flat mode is enabled.

C7 - Early CPU init Exit
March 3, 2011 12:08:08 AM

Was all this after changing the unganged > ganged? What i mean is, entering bios > changing unganged > ganged. Then turning it off, replacing the sticks to blue/blue or white/white then booting up? If so...

Can you clear the CMOS on your motherboard? This should set the BIOS settings to default. These wacky settings should not be appearing on first boot up.
March 3, 2011 12:10:33 AM

it was after, when I posted my message about will do so now, it was already in ganged mode.

Not real sure on how to clear the CMOS.
Can I clear the CMOS within the BIOS?
March 3, 2011 12:15:11 AM

http://pcsupport.about.com/od/fixtheproblem/tp/clearcmo...

there's a couple of ways, all of which should lead you to the same end. If you don't want to clear the CMOS using the jumper on the motherboard or the battery, as many people want to steer away from doing it hands-on way, you can simply "Reset to Factory settings" in BIOS.
March 3, 2011 12:17:05 AM

I looked on google as well. there are two clear cmos switches.

One on the back where the I/O panel is.
Other is on the Mobo.

I will do the I/O panel one.

After I clear CMOS, do you want me to put both sticks in the blue/blue or white/white slot?
March 3, 2011 12:18:20 AM

Well, either one. I think you should be set on dual channel mode by default in BIOS, thus either one would *should* work.
March 3, 2011 12:19:02 AM

alright, will clear CMOS and move the RAM. Will be back in a few...
March 3, 2011 12:29:00 AM

Alright, test completed.
Blue/Blue get the three errors above
White/White I get 2 other errors
D5 and D0
Don't know their meaning. American Megatrends is the BIOS

In either case, no beep, no POST, no video.

EDIT2:
I have 20 minutes left to do any troubleshooting, after that it'll have to wait until I get home from work.
Current time 840pm CST (-6 GMT)
I get home around 7am CST.

Will try and troubleshoot until last minute.

Also, I have 1.60 for my BIOS, and the ASRock website's latest version is 1.60 as well.
March 3, 2011 12:45:20 AM

It sounds like your ram may be funky. I'd send it back for an RMA.

http://gskill.us/forum/archive/index.php?t-6466.html

that thread may help you out some. May want to post a thread on the gskill forums as well and see what happens. It's very strange that you can't change the voltage to a lower setting on that board. BTW, which CPU are you using?

There is the method of using 1 stick at a time to see how each one responds. Put one stick in each slot, see what you get and if you're able to change the settings and memtest86'ing each stick this way until finally setting them both in.
March 3, 2011 12:50:44 AM

AMD 955 BE.

I'm waiting for their admin to activate my account, until then can't post on GSkill's website.

Will read that post as well.

Any other suggestions? Do you think the RAM is bad even though all 4GB is being read in single channel?

EDIT:
Missed your edit.

You are suggesting that I run 1 stick in A1, run memtest, repeat in slots B1, A2, and B2? Then repeat for stick 2?
March 3, 2011 12:55:50 AM

Put 1 stick in a A1, A2, B1, B2 and memtest each stick just once, not once for each slot. Repeat this process for the second stick.

You should also try to set the correct timings / voltages according to GSkill's website for each stick in each slot and see if it boots. Then, finally, sticking them both in there under blue/blue white/white.

Ultimately it comes down to either the RAM, Motherboard or memory controller on the CPU. If it boots on 1 stick in each slot under correct timings, or two sticks under single channel slots it should point more definitively toward a particular direction. What that direction is, though, i'm not too certain. But doing this will certainly help them in fingering the culprit.

I'm all out of ideas, but I hope i've been at least somewhat of a help :p 
March 3, 2011 1:03:50 AM

I'm not following?
I'm not understanding something, so please forgive me...
What do you mean by 1 stick in A1,A2,B1,B2 then memtest each stick once? 1 stick can't go in all 4 of them at once (like I said, I'm misunderstanding something).

I can't test any more tonight, getting ready for work. I will reply sometime around 7am CST (-6 GMT). Since I can't use 1.5v per GSKill, will 1.547 be ok (I'll look to see if there's a 1.4??v that's closer to 1.5 than the 1.547)?
March 3, 2011 1:08:01 AM

Just take the 1 stick and put it in A1, boot up and check the timings/voltages. Power down, put it in A2 and repeat the check on timings/voltages, then B1, etc. After you've finished the first stick then take the second and do the same.

Well, that bios should have small incremental voltage changes.

For example: 1.48 > 1.5, not starting at the 1.547v. Have you tried auto set on the voltage?
March 3, 2011 1:09:13 AM

Just changed the timings to match GSKills (8-8-8-24)

DRAM Voltage is set to 1.547v

Other selectable values are:
1.407
1.477
1.5 - this missing magical one(it's not there, just listing it)
1.547
1.561

EDIT:
I posted this before your response.
the 1.547v is selected by auto.
March 3, 2011 1:11:55 AM

And the ram is being recognized as 1333 / 10666?
March 3, 2011 1:21:33 AM

yes, it's being recognized at 1333 (think it said 667mhz or something...but said it was 1333).

I haven't done any testing yet, but at this point what you want me to try when I get home from work is...
Stick 1 in slot A1/A2/B1/B2 (1 stick at a time)
Stick 2 in slot A1/A2/B1/B2 (1 stick at a time)
Record timings

Want me to select 1.477 since it's lower than 1.5v?

Please let me know any thing else (and/or correct the above tests) you want me to try when I get home.


EDIT:
Thanks you for your help, pelov, I really appreciate it.
a b } Memory
March 3, 2011 2:06:39 AM

(1) gang/ungang has to to with CPU (single core/multicore - Should be in default pos (Unganged)

(2) If you do not have the latest BIOS, I highly recommend that you upgrade to the lastest version - Many times that fixes problem such as this. Important - Use only one stick of memory and test this memory using memtest prior to flashing your BIOS. If you have a memory issue, and you flash the Bios you can corrupt it.

As an alternative to memtest 86 (from a bootable CD), you can use Prime95 in windows.

Memtest86 - Download the ISO and use the create ISO function (you can not just copy like data to a CD). If using win 7 just drage the ISO to the CD/DVD drive
http://www.memtest86.com/download.html

Here is the site for Prime 95. (i find prime 95 identifies mem errors better than memtest86).
http://www.mersenne.org/freesoft/
March 3, 2011 2:41:35 AM

1) Tried both, unganged first, since it was default, per pelov suggestion tried ganged. no difference.

2) The BIOS is current, version 1.60, no new upgrades available, as mentioned above.

I have downloaded memtest86+ and put it on my bootable USB device. Have not ran it yet, plan on dosing so when I get home from work tonight. (7am CST -6GMT)

I have Prime95 as well. I just don't know which test to run, it gave 4 different options. the 4th being custom. I'm not at home so can't remember what the first 3 were.

I'm open to all suggestions. I'm going to do the test pelov suggested. try one stick in all 4 slots (A1,A2,B1,B2) & record the timings. Do the same for the 2nd stick.

Then run memtest86+ on both sticks in A1.

I can also run Prime95, just would like assistance on what to run.

If you feel that my plans for the morning should be changed, please let me know and I will change accordingly.
a b } Memory
March 3, 2011 1:48:08 PM

Prime95 - I normally use "Blend"
Your plan seams good.
March 3, 2011 8:55:00 PM

I didn't do the testing (was too tired after work), but ASRock finally contacted me. They said it sounds like a DIMM slot issue on the mainboard. I'm guessing I should RMA the mobo?
March 3, 2011 10:46:18 PM

Yea, if they said it may be a DIMM issue then RMA it. Where did you buy it from?

Though it says it may be a DIMM issue, which it might be, the IMC (internal memory controller) on the CPU may be at fault as well. The problem with that is that it's difficult to diagnose and generally a toss-up between ram/mobo/CPU.
March 3, 2011 10:52:52 PM

NewEgg.

I don't think it's the RAM, since both sticks are fully being registered (4GB in BIOS & 7).

Might be the CPU or Mobo, will go route of mobo first.

Their exact words were:
"Its seems like a mainboard DIMM Slot issue to me, I suggest you contact the vendor for replacement. Sorry about the issue you are having"
March 3, 2011 11:02:58 PM

Yea, that's why the trick of using 1 stick at a time on each slot and setting the proper timings/voltages and a memtest86 run usually eliminates the RAM as the culprit. If the ram isn't being recognized in a particular slot then you know it's the mobo. As for the IMC, i'm not too sure... I believe that can cause a whole host of problems :p 
March 3, 2011 11:29:39 PM

I never did the test with each stick in each slot. Should I still go ahead & do so?
March 4, 2011 12:06:51 AM

Tbh, I'd go with the safer bet and just RMA it, considering they themselves told you to do so.
!