Sign in with
Sign up | Sign in
Your question

USB HDD not detected at all!

Last response: in Storage
Share
July 29, 2012 11:45:06 AM

Hi Everyone,

I know this kind of topic has been covered over and over again, but none of the situations described seem to fit with what's happening to me.

I have a "Maxtor Basics 500GB" external USB HDD which a few months ago stopped being visible in "My Computer". I immediately tried looking in Device Manager, and then Disk Management - with no luck. The device would power up, make the right noises and the green LED on the front would come on and stay on as it normally does. With this in mind I tried the HDD in a second, then third computer - no luck either.

At the time, I found a thread outlining similar problems. It was suggested that the HDD enclosure may be defective and it might be worth removing the Hard Disk (a Seagate Barracuda 7200.11 500GB) and trying to connect it via a USB connector.

I've finally got around to that today, and the disk is now connected to my HP Pavilion G6 Laptop via a Nikkai SATA/USB adaptor - but still no luck. The Disk starts and makes all the right sounds - but still nothing in Device Manager or Disk Management.

I can't see anything obvious in the BIOS either - but not sure I'm looking in the right place as I can't find the Hitachi HDD that is built into the Laptop either. I've had a really good scour through, and looked at all of the pages, and there's nothing - it seems to lack a lot of the advance functions that I would have expected to see on a BIOS, so presumably HP have dumbed it down to stop people fiddling.

I am pretty much out of my depth now, so would really appreciate a few pointers? The hard disk is my other partners and has a lot of non-backed up data on it that is very valuable on a personal level.

If you need any more information please ask.

Many Thanks in advance,

Matt

More about : usb hdd detected

July 29, 2012 2:25:53 PM

Hi Guys

I have the same problem. One of my clients brought a seagate HDD to me because the OS would not start up and I discovered it was not being detected in the bios

I put it in an enclosure with still no luck. There is 3 years of important data on it and the drive still spins up?

Could it be the HDD controller board and I have to send it to a lab to have data recovered.

I could recover the data myself if the HDD was discoverable in bios or via USB

Regards
Roger
MCSA
July 29, 2012 5:28:32 PM

Ok, so I've now tried the HDD on a computer that I can actually use the BIOS on, and it's definately not there. I've now also tried adding it to a spare slot on the mother board. I've also tried it on a computer running XP professional, just in case it was an operating system problem.

Any ideas anyone? I'm thinking HDD control board too - but I suspect sorting that out is well out of my capabilities!

Thanks,

Matt
a c 311 G Storage
July 30, 2012 1:29:42 AM

Seagate's 7200.11 and Maxtor DiamondMax 22 drives are afflicted by the 7200.11 BSY bug. Seagate may offer you free data recovery if your drive is affected. Otherwise there is a cheap and relatively easy DIY fix.

Seagate 7200.11 BSY bug and 0 LBA fix:
http://sites.google.com/site/seagatefix/
http://www.msfn.org/board/index.php?showtopic=128807
http://www.overclock.net/hard-drives-storage/457286-sea...
http://forums.seagate.com/t5/Barracuda-XT-Barracuda-Bar...
!