Sign in with
Sign up | Sign in
Your question

Flaky power supple or just me.

Last response: in Components
Share
August 9, 2010 2:04:07 AM

Just finished a build, plugged it in, power supply is receiving proper voltage but no response from any components.Checked 24 pin connector with a plug in power connector checker. The -5volt light failed to come on while the others lite up. Interestingly the fans worked with the checker plugged into the 24 pin connector and the 8 pin connected to the motherboard. Unplugged the 24 pin from checker, connected back to motherboard and once again no response from computer.
Any ideas---is 750 power supply not overdrawn.

More about : flaky power supple

a c 272 ) Power supply
a b V Motherboard
August 9, 2010 2:06:40 AM

What 750W power supply do you have? What are the other specs of the system? Do you have another power supply that you can use in the system to check and make sure its not the motherboard? Have you check to make sure its not the power button on the case thats causing issues? What the tester does it is shorts the green wire on the 24 pin to a black wire just like what the power button causes so when you had the fans plugged into the power supply and the power supply hooked up to the tester, the power supply was ON, so i find it more likely its a motherboard issue.
m
0
l
a b ) Power supply
August 9, 2010 2:38:43 AM

Even if your psu can put out enough watt's, if it is a no-name brand then it could very easily be defective.
m
0
l
Related resources
a b V Motherboard
August 9, 2010 3:11:36 AM

Modern power supplies don't have the -5v on the 24 pin, that's normal. I've tested tons of working PSUs, so that's not the problem.

Plug in the 24 pin, and only one 4pin of the 8 pin, try it, if no go, try just the other 4 pin with the 24 pin.

Bread board it outside the case to make sure its not grounding.

Is your ram on the QVL?

Is your CPU on the QVL?

Is the ram plugged into the right slot?

Try with less ram?

Jump the on pins with a screwdriver?

You really haven't given enough info, to diagnose the problem.
m
0
l
August 10, 2010 9:25:57 PM

Sorry for the lack of info. New to all of this.
Gigabyte GA-x58A-UD3R MB
Etasis ET750 power supply
Intel I7 930 Processor
Cosair XMS3 6GB
Intel Solid State Hard Drive
Western Digital Raptor
Western Digital Black x2
Azza case

Checked power switch showing 5v on meter
Used single memory stick in slot 3 (tried all 3 sticks)
Attatched known working 650 watt power supply
Bread boarded the MB
Disconnected the peripherals when checking above
Verifed front panel connections
Still not running

I am not sure what QVL means or what pins I need to jump.

Thank you for your assistance
Kim
m
0
l
a b ) Power supply
a b V Motherboard
August 11, 2010 9:02:18 AM

jump the pins where the power switch connects to the motherboard to rule out a faulty power switch. And make sure the power switch is connected to the correct pins on the motherboard. Also, Disconnect all components except for mainboard and try to power on. If it responds then one of the components is taking down the power. Add a component one at a time to find the faulty part. basic fault finding...
m
0
l
!