Sign in with
Sign up | Sign in
Your question
Solved

Issue updating Drivers Mobility radeon HD 4870

Last response: in Graphics & Displays
Share
May 3, 2010 5:02:25 AM

I have tried everything.... I have reinstalled windows 4 times, tried these drivers 10.3, 10.5, 10.6 and 9.12 modded none of them will recognize my 4870. the only one that will detect my card is the stock dell drivers. I have used driver sweeper in between and have tried installing those vid drivers first on a fresh install. IDK what to do anymore or what I can do to fix this issue as the Dell drivers are not the best and i really would like to use 10.3. My questions are:
1) is my card bad?
2)why can the dell drivers pick up my card, but all the rest cant?
3) what can I do to fix this?


I dont know if this is a software issue or a hardware issue seems to me that it cant be a software issue as these all where tried on fresh installs and not so fresh ones and each time it does the same driver is not detected and all it does is install catalyst install manager and there are errors(log below from 10.3)





Please help :( 

My specs:( if relevant)
Alienware M17xR2
Core i7-720QM
8 gigs DDR3 1333mhz
256 GB SSD
ATI radeon Mobility 4870

a b \ Driver
May 3, 2010 5:36:41 AM

I found this bad news

AMD/ATI is under orders by the OEMs NOT to DIRECTLY provide drivers for their Mobility cards. However, by using DH Mobility Modder you can update the drivers for the Mobility cards.

The mobility modder does not work for crossfire cards.
m
0
l
Related resources

Best solution

a b \ Driver
May 3, 2010 7:16:35 AM

Where are you downloading the driver? from AMD's site or Dell ?
Share
May 3, 2010 7:51:39 AM

I downloaded from the Link i posted above But I actually figured it out I just did a manual driver install through the device manager and pointed it to C: ATI/support/10-4_mobility_vista_win7_64_dd_ccc and it installed Should have tried that sooner but I completely forgot about doing it that way Thank you for your replies though
m
0
l
May 3, 2010 7:51:54 AM

Best answer selected by mkelliny.
m
0
l
a b \ Driver
May 3, 2010 9:19:30 AM

Mkelliny said:
I downloaded from the Link i posted above But I actually figured it out I just did a manual driver install through the device manager and pointed it to C: ATI/support/10-4_mobility_vista_win7_64_dd_ccc and it installed Should have tried that sooner but I completely forgot about doing it that way Thank you for your replies though

Glad its working fine then :) 
m
0
l
!