Sign in with
Sign up | Sign in
Your question

Help!! my motherboard won't support DDR2 1066 ram

Last response: in Motherboards
Share
March 4, 2011 3:43:07 PM

My current build is Gigabyte MB MA770-UD3
AMD Phenom II X4 940 BE 3.0 GHZ
4x2gbs Kingston 1066mhz
AMd Radeon HD6870 1Gb GDDR5

I also have the problem that when i boot the computer it reads the memory at 800mhz. I know my CPU supports 1066 but does my mother?
My bios version is F8 I tried updating it to higher but Q-flash doesn't work nor @bios. Any ideas on how I can have my motherboard run the memory at 1066mhz instead of 800?


a c 107 V Motherboard
March 4, 2011 3:50:35 PM

The BIOS has an option to change the RAM speed. If you can't find it in the BIOS itself, the manual should have all of the important BIOS settings explained.

What do you mean, Q-Flash and @BIOS don't work? What happens when you try them?
m
0
l
March 5, 2011 2:26:54 AM


@bios software gives me an error! it reads like this.. " Bios partnumber(AWARD)is not correct" then it cancel the process.
Q-Flash utility V. 2.13 gives me another error when I choose the bios file from the floppy disk it says, " Bios ID check error" then nothing happens after that.
m
0
l
Related resources
March 7, 2011 11:28:13 PM

[Solved] I solved the problem me self, They are three type of chip revisions on my motherboard so I figured which one was mine. Then I was able to update the bios to the latest and now I can use my brand new Phenom II X6 1100T with the kingston 1066 mhz ram. Thanks for the help either way.
m
0
l
April 3, 2011 3:43:37 AM

Problem was solved by myself
m
0
l
!