New pc build not powering on second try

after assembling my new pc i cut it on with all lights and fans running in case but no video on monitor, so i hit the power button, then held in the power button a few secs and it didn't turn off so i unplugged it from the wall socket. after checking things out and plugging it back in, i attempted to power it back on and nothing happens at all, no lights, fans etc. did i break something or need to reset something?

antec 300 case
msi 870a-g54 mobo
ocz stealthxstream 600 psu
phenom II x4 955
3 answers Last reply
More about build powering
  1. antec 300 case
    msi 870a-g54 mobo
    cz stealthxstream 600 psu
    phenom II x4 955
  2. We are going to need your entire configuration (model#s, etc.).

    Your best chance at solving quickly is this (expert troubleshooting) checklist.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    "System won't boot" and "no video output" checklist

    This checklist is a compilation of troubleshooting ideas from many forum members. It's very important to actually perform every step in the checklist if you want to effectively troubleshoot your problem.

    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-boot-video-problems#t1895014


    = Al =
  3. ok thanks, didn't do step 2 (cpu power plugs), so try that out, but why did it fire up the first time and not anymore if thats the problem?
Ask a new question

Read More

New Build Power Systems