Solved

Urgent help with SATA Hard Drive!

Hello,

I need help please, my old laptod died (along with 400 pages of my book which I had no back-up) and when I took it to a computer store they aid I could recover my files if they removed the hard drived and put it in case and so on.

Today I got this case with a USB cable that has one 'head' in one side and two in the other, I plugged both the ' heads' of the same side on my new laptod.

And lo, and behold it seems that my folders are there under something called Windows.old therein lies a folder my user name, the problem is that when I click it says that I have no permission and that if I want to have it to click Ok.

So I click it, the green bar above the window starts to load but doesn't move when its about to finish, its not opening anything and the window is generally freezing and I have to close it.

Please, PLEASE! I beg of any of you learned gentlements to help me with this problem, I am doomed? Or is there something I am overloooking.

Thanks a lot in advance!
7 answers Last reply Best Answer
More about urgent sata hard drive
  1. Make sure you are logged on as administrator.
  2. I am >.<
  3. What's the old operating system and the newer one ?
  4. Win 7

    Edit: Managed to do it, dunno how it just...happened.
    Now I want to deleate the rest of the stuff to use it a a sotrage device but... it wont let me deleate anything, claiming i need permision...which I have.
  5. Best answer
    Had that happen to me but was lucky extra drive and format worked. Here is something that might work http://www.sevenforums.com/general-discussion/20157-can-not-take-ownership-order-delete.html
  6. Worked all fine in the end.
    THANKS A LOOOOT.
  7. Best answer selected by Zigurat.
Ask a new question

Read More

Hard Drives Storage