Sign in with
Sign up | Sign in
Your question

Format Utility for Samsung Internal HDD?

Last response: in Storage
Share
July 31, 2012 7:35:43 PM

Hi folks,

I have a 640 Gb Samsung hard drive (model HM641JI) that is leftover from when I upgraded my laptop to a SSD. I want to use this as my data drive in the new system I'm assembling. I want to use a bootable utility to format the drive. I can't seem to find any software that will work.

I first tried the HDD Low Level Format tool, with the Samsung plugged into a Thermaltake USB SATA dock; Windows won't let me touch the drive because Windows 7 is installed on it. Then I read that Seatools works with other brands besides Seagate. Seatools works perfectly with my two Seagate drives, but when I use this Samsung drive with Seatools, the options for stuff like timed erase and full erase are missing from the "Advanced Features" menu. When I try to search for Samsung Drive utility, it keeps linking to Seagate. The only Samsung utility I can find is for external USB, and I believe it only runs within Windows.

Does anybody know of a bootable format utility that will work with Samsung internal SATA drives? Any help would be greatly appreciated.

Cheers.
a b G Storage
August 1, 2012 12:58:02 AM

You should be able to format the drive from within Windows as long as it is not the boot drive. So if you have it loaded into your SATA dock, Windows shouldn't complain if you try and format it.
m
0
l
August 1, 2012 4:00:20 AM

Hi Scott,

That's exactly what happens, though. When I had another HDD (a 3.5" Seagate) plugged into the Thermaltake dock that was also a boot drive, the same thing happened. HDD Low Level Format Tool scans it for a while and then says "can't unlock the drive". That same HDD worked after I wiped it with Seatools in DOS; unfortunately, this current drive I'm working with can't access the advanced features in Seatools. I tried booting into Ubuntu from an ISO to try and access their disk format utility, but it wouldn't work.
m
0
l
August 1, 2012 1:54:28 PM

Problem solved. I downloaded the Samsung Format Utility, which is only supposed to work with their external drives, but it worked with my HDD plugged into the Thermaltake.
m
0
l
!