Sign in with
Sign up | Sign in
Your question

DRAM_LED is Red - No display on monitor (first boot)

Last response: in Motherboards
Share
March 5, 2011 5:39:29 PM

Hey all - I just completed my first build and was rather meticulous about the whole process. I just turned on the power this morning for the first time and to my dismay there was no display.

Before I take everything apart and "breadbox" it, I wanted to see if maybe there's something else I can try. I've already retraced my steps and made sure that I didn't miss anything obvious.


My largest suspicion is that the issue comes from my RAM. I accidently bought the wrong set of RAM which is at 2000 mHZ, which my Sabertooth X58 doesn't have listed in its list of compatible RAM. The DRAM_LED is on - which led me to even further suspicions. The only reason that I doubt this as the issue is that my friend with a background in IT told me that on the first boot my Motherboard would default the RAM down to 1066 Mhz anyway, removing the problem. Either way, I'm quite skeptical.

I tried the MemOK! button - Which supposedly should make the RAM compatible with my Motherboard (temporarily?). If I quickly press it the system just restarts and sits there on with no display as before. If I hold it down, as advised by the manual, the system restarts and then the CPU_LED stays on until I let go. The DRAM_LED doesn't start blinking - as the manual said it would if it is undergoing the tests for my RAM.
Oh, I also tried rotating through each stick (1 at a time) and I tried changing which slot I seat it in (incase somehow I was reading the Mobo wrong). None of these attempts changed anything. OH, and I have tried my monitor on another computer - it worked fine.

So what would you guys reccomend? Should I be confident enough that the issue is my RAM and go out and just purchase a set from Best Buy (so I don't have to wait for shipping...)? Or should I just buy 1 compatible stick and test if the RAM is really the issue? Or neither?


Some another helpful notes I thought of last minute:

The friend said that the Arctic Silver 5 I used is rather conductive and if I used too much (possible) I could have caused a shortage - although I have no sign of this...

I used an anti-static wrist band throughout the build and I didn't notice any static whatsoever.

When I boot I only hear a click for the LED's and a quick noise that sounds like the bleating of a lamb - is this the motherboard? I plugged in the HDA connector from the front panel (I had the choice of that or AC 97)... Is that for the motherboard audio?


Here are my specs:

Case - Antec twelve hundred V3
Graphics card - Asus GTX 560
Power Supply - Antec CP-1000
RAM - Patriot Viper Extreme 6gb (3x2gb) DDR3 2000Mhz
CPU - i7 950
Motherboard - Asus Sabertooth X58
HDD - Hitachi 1TB 7200 RPM Sata
Fan - Cooler Master Hyper 212+
SSD - OCZ Vertex 2 60GB
Monitor - Asus 23.6" widescreen



Please just ask if you need any other details. I took some pictures (Low quality iPhone -_-) for that friend of mine but I don't know how helpful they are exactly...

All help is much appreciated. I can't wait to make this thing work.
a b V Motherboard
March 5, 2011 6:24:40 PM

Do you have a case speaker connected to your motherboard?
m
0
l
March 5, 2011 6:53:23 PM

I didn't have a connector for the digital audio connector (4-1 pin SPDIF_OUT) if that's what you're referring to.
m
0
l
Related resources
a b V Motherboard
March 5, 2011 6:54:16 PM

^ Nevermind my last post. You might need to hold the MemOK! button down longer.
m
0
l
!