Please Help

Hi,

I have a WD 1TB MyBook Essential. Recently the device would not power on (no lights, no disk spinning…nothing) I tried multiple power outlets in the house with the same results. So I removed the hard drive from its original WD enclosure and purchased a USB to SATA docking station. The docking station works. It will read a 2.5 Seagate 160 GB laptop hard drive and a 2.5 WD 320 GB Passport. But when I insert the 1TB WD MyBook I can hear/feel the drive spinning, but it does not show up in My Computer or under Disk Management. I have data on the 1TB hard drive that I need to access. Any suggestions would be greatly appreciated in order to solve this problem.

Thanks,

-Spiker
3 answers Last reply
More about please help
  1. Does sound like the drive has died. If you can not see it, the interface electronics may have failed. Have you tried contacting WD support? It is likely that unless you are willing to spend a fair sum with a recovery specialist, you have lost your data. How old is the MyBook?
  2. Hi,

    Thanks for the quick reply. I got the MyBook sometime in 2008 (I think). I voided the warranty though when I opened the original WD enclosure. The drive does not make any clicking noise except for the usual sound it makes when the drive is first being accessed (it's a muted clicking and it stops after 2 seconds). I'm really not planning on spending money for data recovery. I've read that MyBook uses 128-bit hardware encryption, and I'm wondering if that may be the issue as to why I can't see the hard drive in My Computer or Disk Management...
  3. If it was working you would see the disk as a piece of hardware in disk management. You would not be able to get to the data without decryption.
Ask a new question

Read More

Hard Drives Western Digital Storage