Samsung 830 Not Getting Good Benchmarks HELP!

Ok, just bought a 256GB Samsung 830. Fresh install of W7 64bit, AHCI enabled in the bios. Installed all the drivers that came with my mobo etc. Drive is connected to one of my two SATA 3 ports with NO other SATA ports currently being used. Mobo is H67M-ITX.

Ran AS SSD and CrystalDiskMark and I'm getting poor benchmarks.

Seqencial read is 261.05MB/S
Write is 247.29MB/S

This drive should be reading at around about 500MB/s. Any idea why it isn't maxing??

Someone else on a different forum had a similar problem and said "IT'S MARVELL CONTROLLER'S FAULT!!! So I switched to intel ahci controller then problem solved!!"

But I don't know what that means/how to do that.

PLEASE HELP!! :)
1 answer Last reply
More about samsung good benchmarks help
  1. Double-check that your drive is connected to port SATA_0 or SATA_1.
    See page 12 of your motherboard manual for the location of the ports.

    Your SATA cable should be able to transfer data at 6Gb/s speeds but some poor quality SATA cables don’t. If you’ve verified that your drive is connected to port SATA_0 or SATA_1 then try changing cables.
    This site sells good quality cables: http://www.monoprice.com/products/product.asp?c_id=102&cp_id=10226&cs_id=1022602&p_id=8782&seq=1&format=2


    jamesclark1991 said:
    Someone else on a different forum had a similar problem and said "IT'S MARVELL CONTROLLER'S FAULT!!! So I switched to intel ahci controller then problem solved!!"

    But I don't know what that means/how to do that.


    Your motherboard does not have any Marvell SATA ports, only Intel, so that doesn’t pertain to you.
Ask a new question

Read More

SSD Samsung Storage