Sign in with
Sign up | Sign in
Your question

Redhat 7.2 Installation Probs

Tags:
Last response: in Linux/Free BSD
Share
November 5, 2001 1:26:44 AM

hi guys, i'm a complete newbie in Linux and *nix, so pls bear with my stupid questions...

i've just download Redhat 7.2 (only some RPMs) via FTP...
i've dumped all of them on my Windows primary partition (c:) 
i've already partitioned another drive (d:)  with windows fdisk
i read a website which says that i could re-partition my HDD with Linux fdisk during the Linux installation, so i don't have to partition now
i've also burned the files into 2 CD-Rs, and made a linux boot disk...

i can boot up with the boot disc and start the installation, but whenever i reached the point of choosing the media for installation (CDROM or HDD), i get errors:
the installation couldn't find and installation CD-Roms, nor could they find any HDD on my system...

i've tried various CD-Roms - the CD with the file
enigma-i386-disc1.iso, the CD with enigma-i386-disc2.iso, and also the Disc with a Redhat subdirectory and all those Dosutils stuffs...
however, the installation just couldn't find any Redhat CDROM...
it did read my CDROM drive though...
i can't install from my CDROM, neither from my HDD
i won't want to do an FTP install as it took mi hours to download the stuffs even through a cable connetion

my system specs are:
AMD Athlon 1000
Kingston 128MB Ram CL2.5 @ CL2
Abit KG7-Raid Mobo
2 Maxtor 20GB HDD in Raid 0 Config (Striping) - 24GB primary partition, another 16GB i wanted to reserve for Linux
Inno3d GeForce 2 GTS Card
Sony CD-RW
OEM 52X CDROM Drive

anyone can help me with the installation prob???
also, can i just use the default Linux booter to dual-boot with windows so that i don't have to buy Partition Magic or System Commander???


EcOnOmIc ReCeSsIoN = No NeW CoMpUtErZ FoR mE
Anonymous
November 5, 2001 2:59:44 AM

I wonder if the problem is the raid mobo? Where have you got your cdrom plugged into? raid port or regular ide?

It doesn't just want a disk full of rpms, it wants the extra files that go with them, starting from the top level dir (i386 in this case)... If it can see a disk, but doesn't know it's a redhat disk, i suspect some files are awol. it'll be something small and unimportant looking.

The ISO's should be the easiest way, but check the MD5 sum to make sure it's not corrupt.

linux should be fine doing the dual booting for you.
November 5, 2001 7:37:32 AM

yep both my cdrom drives and cdwriter are plugged into the normal secondary IDE
i can't check the checksum of the ISO files in windows i suppose???
would you be kind enough to tell me what are the files required in CD1???
(i forgot to mention that i couldn't boot up with any of the Linux CDs i've burned)

EcOnOmIc ReCeSsIoN = No NeW CoMpUtErZ FoR mE
Related resources
Anonymous
November 5, 2001 9:32:26 AM

um... all of them? I can't give you a list as I don't use RH7.2. But, the files you should have are everything under i386. That includes boot.cat, PGP-GPG-KEY, README, COPYING, autorun, and the directory structures, but you don't need the SRPM's. In the RedHat directory you'll need the Base directory and files, and the RPM directory with its RPMS (obviously...)

If you've got the ISO's life gets easier. Make sure the checksums are ok, and check your BIOS to make sure you're set to boot to CD before HD.

Here's an md5 link I found on the net. I make no promises about the programs accuracy! (but it worked for me)
<A HREF="http://www.iay.pwp.blueyonder.co.uk/threel/tech/tools/d..." target="_new">http://www.iay.pwp.blueyonder.co.uk/threel/tech/tools/d...;/A>

I'd stay away from using the individual files if possible. You should be able to use the CD's, and boot.img + drvblock.img if it won't boot from the CD. It might be worth reading the install guide on the redhat site...
November 5, 2001 11:25:27 AM

i'm not sure if this has been fixed since mandrake 7.1, my friend had problems oinstalling that and he is running raid setup. the problem is that it doesn't like raid to well it always corrupted the harddirve any ways the best bet is to go and get a small hardrive to keep every thing seperate snice for one linux can't do more then ata 66 ( it gives you an eeror if you set it to 100) also you a much less of a chance to corupte either system if they are seperat

<font color=red>Gasoline + Fire</font color=red><font color=green> Can be a lot of fun</font color=green> :smile: :smile: :smile:
November 5, 2001 12:06:43 PM

thanx for your reply
i honestly don't wana get a new HDD since i'm low on cash...
i also won't want to get rid of my Raid array (otherwise all my valuable MP3s will be gone!)
anybody has any other solutions?


EcOnOmIc ReCeSsIoN = No NeW CoMpUtErZ FoR mE
November 5, 2001 12:11:36 PM

i've checked all my checksum for the ISO images, no problems with them...
i've also created a new boot disk with drvblock.img and boot.img, but the installation still couldn't read from my cdrom drive and cdwriter...

i used the CD with the image file enigma-i386-disc1.iso
the disk wouln't boot either...

i've autodetected the CDROM drives in my Bios - they're detected properly...

this seems pretty funny... do i have to load any cdrom drivers before the installation or anything???
do i have to mount any drives???
is there any special Raid drivers for Linux that i need...

also read the installation guide at redhat.com - doesn't seem to have missed our any steps

EcOnOmIc ReCeSsIoN = No NeW CoMpUtErZ FoR mE
Anonymous
November 5, 2001 12:36:59 PM

hey.

you did an "expert" mode installation? that's how you get to load the drivers first. eg type `linux expert` at the boot prompt.

one thing, and don't take this wrong, but you said "a new boot disk" - singular, drvblock.img and boot.img should be two floppy disks. sorry if it's a typo but it struck me as odd and i figured i'd better make sure.
November 6, 2001 7:31:20 AM

ok thanx everyone for your help and attention!!!
i finally solved the prob - by using another CD Writer Program to burn the ISO image...

but, guess what, i got another problem :( 

after selecting a Server installation, i got to the Fdisk and Diskdruid part...
i chose to manually partition with Fdisk, but an error came out:
Linux said that it did not understand the file system on device hde and it would have to initialize it, but all data would be gone...
the same error came up for device hdf

both devices are my physical hdd - maxtor 20GB hdd..
but i'm using an onboard Raid controller with Raid 0, but it seems that the installation could not understand this...
i really don't wish to throw away my Raid 0 as all the files on my Widnows partition would be gone...

anyway, i've already reserved some space for Linux - 15GB to be exact...
since Linux couldn't understand this, i used Partition Magic to create a Linux logical partition and a swap partition - but the same error popped out...

i got the latest Linux drivers from my Raid manufacturer and made a bootup disk with rawrite - but still no use...

i also don't wish to buy a new HDD just for my Linux...
my old EIDE HDD also would not be recognised by the Bios (latest version)

could anyone help with this???
perhaps is there anyway for my to install the kernel image to a floppy and boot up with the floppy, while the Linux files still reside on my Linux partition on my Raid array???


EcOnOmIc ReCeSsIoN = No NeW CoMpUtErZ FoR mE
Anonymous
November 6, 2001 9:46:29 AM

I found this @ <A HREF="http://www.icrontic.com/faq/kt133.htm" target="_new">http://www.icrontic.com/faq/kt133.htm&lt;/A>

14.1 A word about the HPT 370 and Raid.

The Highpoint 370 controller is supported in most newer Linux Distributions using 2.4 kernels such as RedHat 7.1 and Mandrake 8.0. Also FreeBSD 4.1 and above support this chip. The actual driver name is HPT366, which is somewhat misleading since it supports the HPT363, HPT366, and most importantly the HPT370. As I understand it, this driver supports single disk functions only, and hardware-based RAID with the HPT370 is not yet established, although software RAID is available through the kernel. It should be understood that the HPT RAID controller is a software driven chip (drivers), that is to say that there is no processor or cache on the chip.

also <A HREF="http://linux-ide.org/chipsets.html" target="_new">http://linux-ide.org/chipsets.html&lt;/A>

and <A HREF="http://mandrakeforum.com/article.php?sid=1097?=en" target="_new">http://mandrakeforum.com/article.php?sid=1097?=en&lt;/A>

finally <A HREF="http://people.redhat.com/arjanv/pdcraid" target="_new">http://people.redhat.com/arjanv/pdcraid&lt;/A>

From my understanding of it, you can use the chipset with linux software raid (which appears to be better anyways), but not the pseudo hardware raid that these chips use.

Maybe you can get something working using some cunning partitioning? If you can partition some free space, and linux can see it, you could probably set up linux software raid on the free space, but you may need to use a boot disk to start the (linux) system.

Edit: Having said that, I downloaded the "driver" from Highpoint, and it looks pretty convincing. The pdf docs explain the process quiet well, but being for version 7.1 things might not work with your 7.2 distro...




<P ID="edit"><FONT SIZE=-1><EM>Edited by rjb263 on 11/06/01 06:53 AM.</EM></FONT></P>
November 6, 2001 1:17:13 PM

thanx for that, you did me a great help!!!

i'm using the HPT370
but, i've got a Linux partition (on the Raid controller) and swap partition, but the installation still can't "see" it...

all it "saw" was 2 physical hdd...

so must i really delete the Raid array???

also, you mentioned booting from a boot disk...
is it the same as the disk i made with boot.img and rawrite???
if not, how do i go abt doing it???

sorry for being so lame and ignorant :) 

EcOnOmIc ReCeSsIoN = No NeW CoMpUtErZ FoR mE
Anonymous
November 6, 2001 2:21:35 PM

if it saw _free-space_ on the 2 physical hdd, then you're good to go. just partition the free space as linux software raid (with disk-druid), then let the installer make a boot disk at the end, but don't install the boot manager on the hdd (i think...).


You could certainly try using the <A HREF="http://www.highpoint-tech.com" target="_new">Highpoint</A> drivers. you rawrite the file rh71boot.img (to boot the system), copy the other files in the "rhdd" dir to another floppy, and then see what happens. The instructions are in the .pdf file included.

I really have no idea if it will work or not, but if you can't see free space on the hdd's, and you don't want to wipe your raid, it's worth a shot.
!