Sign in with
Sign up | Sign in
Your question

Windows 7 sound soft-redirected into the microphone

Last response: in Components
Share
August 13, 2010 11:28:04 AM

Hello all.

I've been looking around on different forums for over 2 months now, trying to find an answer to this problem, and the only posts that were even remotely close to what my problem is have not been answered.

Therefore, I'm coming to you as a last resort.

I will expand on the description of my problem in the title. What currently happens, and I've tried this on three separate PCI sound cards, as well as my Realtek Onboard sound card, is that any sound that is sent to the headphone jack is ALSO being sent to the microphone jack.

What happens if I have the "Listen to this device" option checked in the microphone (which causes an echo of the mic input to be sent to the sound output) is that it causes an infinite feedback loop, the mic sending sound to the sound card, and the sound card multiplying it and sending it back to the mic, which then sends it back to the sound card.

This causes an extremely loud scream from my headphones. I can easily stop this from happening by unchecking the "Listen to this device" option, however when I use voice-chat programs such as Ventrilo, other people will be able to hear themselves as if I had a speaker setup, instead of my headphone setup.

This is not an issue with the sound options, because I've combed through every single option and every single forum post that even comes close to this problem with no luck.

I'm currently using Windows 7 Ultimate.

If anyone has any idea why this could be happening, I would greatly appreciate it.

Cheers!
August 20, 2010 2:47:27 AM

Hello all.

Here's an update on my problem. No, I havn't been able to fix it yet, sadface.

It appears that only the sound that is sent to my left speaker is played into my microphone. An example, is that the problem completely disappears when I mute my left speaker.

This, if course, leaves me without a left speaker.

If anyone can help, it would be muchly appreciated!

Cheers!
m
0
l
Related resources
August 30, 2010 12:08:41 PM

Download Driversweeper and install
Start in safemode
Check Creative and Realtek off
Click purge
Restart normal
Download appropriate Realtek drivers from your mobo manufacturers website
m
0
l
September 8, 2010 11:28:32 AM

Hi Davcon, I'm sorry, but your suggestion was unable to fix my problem.

Once I restarted normal and re-installed the appropriate Realtek drivers, the same issue happened again.

Thank you for the info, but I'm afraid it didn't work this time.
m
0
l
September 8, 2010 12:11:14 PM

Something sounds REALLY messed up here; the mic jack should only be an INPUT, and shouldn't be sending anything...

Why does your mic even have the ability to play back audio to begin with? I'm more then a bit confused on that point...
m
0
l
September 8, 2010 12:18:10 PM

Oh yeah. I've never even touched the Stereo Mix, so I have no idea why it's playing my audio (from my left speaker only) directly into my microphone.

Re-installing my drivers have no effect, so I'm beginning to think a fresh reinstall of windows is my only option at this point.
m
0
l
September 8, 2010 5:41:44 PM

Can you give a link to microphone in question? I'm REALLY getting confused on how a microphone is playing back audio...
m
0
l
September 10, 2010 7:08:12 AM

I'm sorry, a link to the microphone in question? I usually use a microphone on a headset, made by different companies. I've used at least 4 different headsets from differing companies on this.
m
0
l
October 11, 2010 1:53:07 PM

I've done this before, but I've really forgotten how. I was playing around with my sound drivers, I can't remember the name... (it has a crab as an icon I think). When I somehow clicked into the part about the microphone, there were many boxes to check to what is inputted into the mic. For example, I could choose the speakers, windows media player, CDs and stuff. So you have to find that place somewhere and uncheck all the boxes other than the microphone. Sorry I can't help you... Cause after I formatted, I was too lazy to install the drivers again...(or maybe i installed it but can't find it)
m
0
l
October 12, 2010 11:55:41 AM

Sorry, I think I may have found the problem. By having two separate headphones plugged in at once -- one for the speakers, one for the microphone, this issue seems to be resolved.

This leads me to believe that both my headphones have crossed wires between the left speaker and the microphone.

What I don't understand is that when I have my actual desktop speakers plugged in and using my headset microphone, this issue is still apparent -- even up to muting the left speaker.

I'll get a new set of headphones and see if that fixes the problem.
m
0
l
Anonymous
October 27, 2010 12:26:58 AM

I came across this while looking for something that sounds like the same problem. Mine went away after I turned off "Stereo Mix" in the Input section of the Mixer tab. (red 'X' through the speaker under Stereo Mix)
m
0
l
!