Sign in with
Sign up | Sign in
Your question

ASrock Xfast Ram created partition on my SSD. Want removal.

Last response: in Storage
Share
August 6, 2012 4:14:14 AM

I am using a ASrock Z77 Extreme4 motherboard.

I was trying out the ASrock xfast ram. Apparently, the application made a partition on my SSD of 509 MB. I am trying to merge this partition back into my main SSD drive.

I read that xfast ram does not help people who have 64 bit OS, which I do.

I tried deleting the partition in disk manager but my drive wont let me extend it. It is grey'ed out.

Please help. Thank you.

Edit: I'm not sure if this will help but...

Anonymous
a b G Storage
August 7, 2012 3:45:25 AM

that has nothing to do with xfast.
Understand (and Get Rid of) the Mysterious Small Partition
Quote:
If you install Windows 7 on a clean disk with no existing partitions, it creates a System Reserved partition at the beginning of the disk and uses the remainder of the unallocated space to create your system drive.That small partition isn’t assigned a drive letter, so you won’t even know it exists unless you look in the Disk Management console or use a low-level utility, such as Diskpart, to inspect the disk structure.


read more on how to get rid of it.
m
0
l
August 7, 2012 3:57:03 AM

I did some research and I think xfast ram created this thing called a ram disk.

The 100MB I know is put aside for the system reserve files. That is not what I am trying to remove.

The partition was made by Asrock Xfast ram because the partition is titled AsRam as default.

If you have not done so already, please take a look at the photo I posted.

edit: I tried deleting asrock xfast ram already and I also used a third party merging tool. None worked. At best, I can remove the partition in disk manager, but I cannot extend it in my C: Local Files.
m
0
l
Anonymous
a b G Storage
August 7, 2012 12:49:23 PM

'im sorry but i do not see it. on disk 0 there is system reserved and the C: partitions
m
0
l
August 7, 2012 12:52:53 PM

Anonymous said:
'im sorry but i do not see it. on disk 0 there is system reserved and the C: partitions


The partition I am trying to merge back into disk 0 is disk 2. Both partitions are from the same SSD.
m
0
l
Anonymous
a b G Storage
August 7, 2012 12:56:16 PM

ah, thanks for clearing that up. sorry i did not understand and don't have an answer.
m
0
l
August 16, 2012 4:45:08 PM

You should be able to fix it by:
1. Uninstall XFast RAM, then Reboot.
2. Open a Command Window and run DiskPart. It will allow you to see and delete Partitions you can't normally see.
Tight for time or I'd give you the step-by steps, but you can just Google DiskPart usage and you'll find it.
m
0
l
August 29, 2012 5:12:57 PM

Im replying beacuse your thread appears on top when you search for xfast ram and ssd, and you clearly misunderstood what xfast ram is and how it's working.

XFast Ram didnt create a partition on your SSD, it created a new RAM Drive, and assigned a letter to it. So it doesnt actually modify your current SSD/HDD partitions.
If you have more than 8GB of RAM, the advantages of the ram drive are huge, even with a SSD, where you can store the pagefile and all the temp files and folders on the ram drive and free your SSD from unecessary writes.
m
0
l
July 13, 2013 10:20:02 AM

6081797,0,887243 said:
I am using a ASrock Z77 Extreme4 motherboard. ....

Take a look at this link http://www.asrock.com/feature/xfast/xfastram/index.asp
XFast RAM is integrated in AXTU (ASRock Extreme Tuning Utility) on mobo Z77.
You might be able to disable FFastRAM in the utility program as mentioned by crisan_tiberiu.
Removing the AXTU might cause you to loose other functions that support Z77.
m
0
l
!