Sign in with
Sign up | Sign in
Your question

Problem getting MB to boot from optical drive...

Tags:
  • Homebuilt
  • Boot
  • Systems
Last response: in Systems
Share
June 14, 2010 11:34:16 PM

Hello,

I have an Abit IP35 pro motherboard, and had it set up with 2 WD 500gb hard drives on RAID. One of the HDs went bad, so now I am trying to revert to a single drive and install a fresh copy of Windows. However, after using the built in utility to change my remaining HD back to non-RAID, I can't get it to boot from CD to start the install process. I have an old IDE DVD burner that I am trying to use, but even when I select for it to boot first in the bios, it doesn't seem to even try, and I just keep getting a disk read error. I have tried both my Windows 7 and Windows XP install disks, so it's not the disk. I don't even hear the dvd drive spin up. Any ideas for me?

More about : problem boot optical drive

June 15, 2010 4:17:54 AM

the optical drive must be hooked up as master on the secondary ide connector.
try that :)  i had the same problem on some dell p4, and so i had to remove all the other ide drives, and even if theres nothing attached to the primay ide connector the optical drive must be the only ide drive, and it must be secondary master. hope this helps!
m
0
l
a b B Homebuilt system
June 16, 2010 4:26:44 AM

An optical drive should be able to work on either IDE port. IF it is the only device on the port / cable, it MUST have its jumpers set to Master and should be plugged into the END of the IDE cable. If it is sharing the port / cable with a HDD, the HDD should be set to Master and the optical drive set to Slave, then plugged into the middle cable connector.

Now, there are other things that could be wrong. You say you do not even hear the optical drive spin up. Well, maybe it's just quiet. Maybe it's actually faulty. Did you plug in its power (4-pin Molex) supply cord? When you try to boot the machine, does the light on the front of the optical drive come on? Have you tried using this drive in another machine to confirm that it is OK? Did you check in BIOS Setup that the IDE port you are using is Enabled? In fact, if the optical drive has power and a valid data cable connection, you should see it detected in BIOS on that port.

You "just keep getting a disk read error". From which disk? Does it say that as soon as the optical unit is accessed, or only after that unit fails and it attempts to access the HDD (has its own access light)?

Have you tried using a CD lens cleaner to make sure the optical drive unit's optics are clean so it can work properly?
m
0
l
Related resources
June 16, 2010 9:16:51 AM

I had been using that optical drive without any problems with my previous install of windows, so I knew it worked, and the BIOS was detecting it. But shovenose was right! As soon as I plugged it into the slave connector on the cable, it suddenly started working to boot from! After messing with some jumpers on an IDE hard drive, I also got that working as well, so I am on my road to a working computer again, thanks so much for the replies!

(btw, turns out that WD HD that went bad was still under warranty, so sent it in today. Gonna install xp on my old IDE HD that I have (had completely forgotten about because it was installed but not plugged in in my case!), and will wait to get my other HD back so I can have RAID again for a Windows 7 install. I need XP anyhow to run some hardware I have, so this works out well!)

Actually, one more issue...before I got that IDE drive working, I tried to install windows 7 on my remaining SATA drive. For some reason, even though BIOS detects the HD just fine, windows 7 says there is no HD attached. It may not be an issue when I set up that RAID array again, but any ideas why Windows setup wouldn't recognize that SATA drive? I know the drive works. I plugged it into a friend's computer and formatted it, but still no dice with Windows setup seeing it on a fresh install...
m
0
l
a b B Homebuilt system
June 16, 2010 4:15:30 PM

You have one SATA HDD in your system but Win 7 Install cannot see it to use? How is the SATA Port Mode set? If it is set to RAID there's a potential issue. If it is set to ACHI mode (or Native SATA), Win 7 ought to see it. If it is set to IDE (or PATA) Emulation mode, it also ought to see it, but AHCI mode would be better.

IF that SATA port mode is set to RAID, what does the RAID Setup screen show? Does it show that SATA HDD as a Member of some RAID array? Or, is is NOT assigned to any RAID array. If it is not being used in any array, it should NOT be a Member of anything.

I'm not sure about this one, but MAYBE if the SATA port is set to RAID mode, Win 7 would need the RAID driver installed at the beginning of Install even though the actual HDD it will use is NOT actually a member of a RAID array.

If you are not using any SATA units for RAID, and don't plan to, you probably would be much better off setting the SATA port modes to AHCI.

Even if all that is set up properly, sometimes Win 7 Install may indicate there is no HDD to use when in fact it means that there is no EMPTY HDD available. IF you plan NOT to try to save any data on the SATA unit, maybe your first step in the Install process will be to use its tools to find that SATA unit and Delete any and all Partitions it already has so it is completely empty and available.
m
0
l
a b B Homebuilt system
June 16, 2010 4:22:35 PM

Just a bit of terminology. Many mobos (maybe yours) have two IDE ports on them (some only have one). They are called the Primary and Secondary IDE Ports. Then EACH of those two can have both a Master and a Slave device on it. So you can support 4 IDE devices on two ports - a Primary IDE Port Master, a Primary Port Slave, a Secondary Port Master and a Secondary Slave. The Slaves are optional, of course. IF any IDE port is in use, it MUST have its own Master.

From what you write it seems you have things hooked up so an IDE HDD is the Primary Port Master and your IDE optical drive is the Primary Port Slave. That's a good arrangement.
m
0
l
a b B Homebuilt system
June 16, 2010 4:52:57 PM

Actually positioning on the cable itself only matters if the cables are set to 'cable select' if the hard drive is master and the optical drive slave, then it can easily have the optical at the end and the hard drive in the middle.

The only reason the SATA drive wouldn't be detected in win7 is if your RAID controller is so bad that for a single drive you have to manually add it alone to a JBOD array. win7 should and has always detected every hard drive in every configuration I've thrown at it. Or because it's still technically half of an array, and the controller doesn't want to jeopardize the data on it.

If the drive you get is new enough from WD you may not be able to RAID it. Apparently they made some switch in the firmware permanent that something causes stuff to fall out of RAID. This is so they can say that you have to buy the RAID class drives if you want to do that.
m
0
l
!