Sign in with
Sign up | Sign in
Your question

ASRock P67 Professional - Black Screen / Error After Post

Last response: in Motherboards
Share
March 11, 2011 11:23:51 AM

Hi All,

Just swapped out my Asus P67 Pro, for a B3 Revision ASRock P67 Fatality (best motherboard I could find with low profile heatsinks to allow sound card in top pci-e x1) and have encountered a strange problem after attempting to install windows for the first time.

Essentially all was well untill I got to the stage at which you choose a User Name / Computer Name, where after clicking 'next' the PC just locked up. I gave it about 15mins before I forced the PC to power off, as I feared interupting a windows installation could be troublesome or at the least require reformat/reinstallation.

From this point onwards the PC now either - boots to a black screen after post with single flashing dash, boots to black 'check error', if I boot into bios instead it either freezes in bios or if I make any changes and reset it fails to reboot. On two occassions I have been able to get it to boot from the windows DVD and started a reinstall of windows - which both times crashed mid way through 'windows is loading files'.

Have check the basics in terms of cables, possible shorts etc. and tried running barebones with just CPU/HDD/1 Stick RAM to no further success (same issues and Dr Debug LED giving no useful code), and have tried using the HDDs on Sata2 / both variants of Sata3 ports - and am not sure what to try next?

All parts bar the mobo are known working, as were thoroughly tested through my previous build which was working perfectly, and temps are good (Noctua D14 properly seated in Raven RV02ew)

Specs; 2600k w/ D14 / P67 Fatality / 8gb Ripjaws / 1tb Samsung F3 / Vertex 2 SSD / HX-850 / Xfire 6870s / Raven RV02ew




Has anybody experienced something similar or have any suggestions?

Thanks

a c 117 V Motherboard
March 11, 2011 5:23:57 PM

If the hdd has info on it from the previous mobo that would definitely cause problems.
Is the O/S a retail or OEM version?
m
0
l
March 12, 2011 4:28:18 AM

OEM version - but thats not an issue.

HDD info was formatted before I originally tried to install and got the black screens and other issues.

Will be returning the motherboard I guess...and waiting for an Asus P67 Pro to be back in stock
m
0
l
Related resources
March 13, 2011 1:56:48 AM

I just installed my ASRock P67 professional board, and it won't POST :S
Computer is running fine, but nothing would show up on monitor D=
m
0
l
March 13, 2011 3:52:33 AM

Yup turned out it was faulty, will be returning it next week.

Swapped it to a new B3 Rev P8P67 EVO (no Deluxe in stock) and worked a treat! (as did my original P8P67 Pro with the Intel SATA fault).

Shame about the ASRock Fatality - looks nice but I guess their quality control is still lagging behind their rapidly increasing designs/specs.

Hope you can work out yours Roadwarrior
m
0
l
March 13, 2011 4:30:55 AM

Roadwarrior, obviously try the usual things (check for shorts, make sure CPU power cables in (and others), but a few other not so common problems that I've experienced with previous builds;

- Try running your HDDs on the Sata2 ports (especially if a Samsung F3, they hate Sata3 ports)
- Make sure you've got a fan plugged into the CPU fan header (I had this issue once when using a fan controller)
- Also if you're using an SSD, when they die they tend to cause the PC to fail to post (and without warning)
m
0
l
!