Sign in with
Sign up | Sign in
Your question
Closed

New ASUS drive won't open

Last response: in Storage
Share
August 8, 2012 6:34:28 AM

Hey guys. I just finished putting together my first build and luckily it all works! Well, everything except my optical drive. It is an ASUS 24x DVD burner. It is recognized in the bios and I know it is getting power because every time I press the eject button, a green light on the front flashes on and then off a second later.

I need the optical drive to work so I can install Windows/run all my installation CDs.

Any ideas?

Thanks!

My build:
Core i5 3570k
Gigabyte z77x-ud3h
MSI twin frozr II 7950
PC Power & Cooling Silencer MKII 750 W
2 x 4gb Corsair Vengeance DDR3
Samsung 830 128gb SSD
Samsung EcoGreen 2TB HDD
Modded Antec 900 case

More about : asus drive open

Best solution

August 8, 2012 6:40:43 AM
Share

Never mind, I tried switching which SATA port on my mobo it was plugged into. Opened right up.

If a mod happens to stumble in here, go ahead and close it!
a c 157 G Storage
August 9, 2012 10:27:18 PM

This topic has been closed by Area51reopened
a c 157 G Storage
August 9, 2012 10:27:25 PM

Best answer selected by Area51reopened.
!