Video Playback issues @ XFX ATI HD 5850 Black Edition

Picture of the issue » http://yfrog.com/ca41842939j

Well I get that error every time when playing 480p Videos of the following formats: MP4, MKV, H.264 on Windows Media Player 11 and Media Player Classic. On Gomplayer video of 480p plays perfectly, except from MKV files, they won't play at all. This have been revealed as issue of ATI Catalyst from 10.1 to 10.4 driver versions.

Original post with pictures @ forums.amd.com/game/messageview.cfm?catid=260&threadid=132395

This is everything I've done:

Tried http://forums.techpowerup.com/showthread.php?t=117633
Tried installing CCCP
Tried playing files with Gomplayer and VLC
Tried with Catalyst Drivers 10.1 , 10.2 , 10.3 and 10.4
Tested the video card on 3 PCs, the same behavior.


Things I'm certain of:

If I uninstall Catalyst Drivers and use windows VGA drivers, it plays the 480p video without any problem.
The issue is only happening on 480p for me, with 720p video or higher it plays perfectly.
My Bios is updated
My video card is not damaged, is brand new and just tested it with certified technician (1 hour ago).
My XFX ATI HD 4890 plays video just fine.

Please if anyone knows an alternative to fix this, please let me know... thx.
3 answers Last reply
More about video playback issues 5850 black edition
  1. Yup, I believe those work under 10.3 but then the other formats are broke...
    Waiting on 10.5 myself.
  2. Try the older driver...
    10.1 below...
    the one inside the CD?
  3. Ok that would be 9.12, downloading...
Ask a new question

Read More

Radeon ATI Video Media Player Graphics