Sign in with
Sign up | Sign in
Your question
Solved

IDE hard drive not being detected

Last response: in Storage
Share
August 8, 2012 6:44:15 PM

Hi everyone

I have an 8 year old Maxtor 40GB hard drive which I've connected to a new motherboard (ASUS P8H67-M PRO). It's for use as a secondary hard drive; I have my OS installed on another one. Well it worked fine until I made the mistake of wanting to try a PCI RAID card (this is something I had bought a while ago but had only tried connecting CD/DVD drives to it: they didn't work). I connected the Maxtor drive to this expansion card through an IDE cable. OS and BIOS didn't detect it.

Then I connected it back to the motherboard just like before and same thing; not detected. Could the expansion card have fried the hard drive through the IDE cable? It doesn't seem plausible since that's a data cable.

Best solution

a b V Motherboard
a b G Storage
August 8, 2012 8:01:06 PM

Not normally but it could have erased/formated all your data. Try a data recovery tool but I'm not very optimistic. Working with an 8 year old drive, you're on barrowed time anyway.
Share
August 9, 2012 6:28:59 AM

Luckily it's working again the problem was a loose PATA cable. :bounce:  But yeah I'm on borrowed time as you said.

(Seems my own answer is best but I can't select it).
m
0
l
August 19, 2012 5:07:08 PM

Best answer selected by seggaeman.
m
0
l
!