Sign in with
Sign up | Sign in
Your question

Bootmgr corrupt, CMOS issues

Last response: in Motherboards
Share
March 13, 2011 3:32:31 AM

Evening.

I have a Biostar TA880GB+ with an AMD quad in it. It's had some trouble booting last few weeks, usually took 2 tries to get it to POST.

Come to boot it this evening after two tries... nothing. Not even a friendly beep of the MOBO speaker. So, jammed on reset a few times, powered on and off. Got it to POST finally.

Screen shows the bottom half of the MOBO splash screen, top is all whited out. Then, gave me the error that "Bootmgr is corrupt. Cannot boot the computer." Odd.

Reset, powered down and up a few times, got to a warning screen before the MOBO splash screen that talked about the CMOS being corrupt. Gave me a few options, forgot which they were, but I selected F2 to reset the CMOS to factory. Got the half splash screen, and then the same Bootmgr issue.

Next I tried to drop the Win7 DVD in to run the Bootmgr repair tool, but can't get it to POST again or boot from the DVD.

My next thought is to fiddle with the jumpers to "Clear CMOS Header" as the MOBO manual states.

Of course, I'd love a second opinion. I've not done anything like this before.
March 13, 2011 1:44:07 PM

I assumed it was, as the message said, a corrupt CMOS. Doing a little research I learned more about CMOS, and decided that if the battery was dead this might be a symptom. Pulled the battery, and it tested fine. Put it all back together and voila, a computer that can boot.

However, getting all kinds of errors as things file into the system tray. Would the Bootmgr have anything to do with that?
m
0
l
Related resources
March 14, 2011 8:43:41 PM

I tried the Win7 Startup Repair tool, and it came back with no errors. Now also the system tray is behaving itself and I've been able to boot it reliably several times. I'm inclined not to screw with the registry, but will file that program away. Thanks!
m
0
l
March 17, 2011 11:39:38 PM

Came across the same errors today, and got a new one.

"A hyper transport link has failed.

CMOS Setting Wrong

CMOS Date/Time Not Set

Press 'Del' to run Steup
Press F2 to load default values and continue"

After I hit delete and re-set the BIOS clock, then hit F10 to save settings, it went to a black screen. Hit the power button several times, took me a half dozen tries to get it to POST. When it did, got this error.

"CMOS Checksum errors."

And the same bit about Del etc, so I went into the BIOS again. Didn't change anything this time. F10 to save settings, black screen, half dozen attempts to boot again, and then POST and Win7 comes up fine.

I started a trouble ticket with Biostar. I have a TA880GB+ and I'm now of the opinion that it's a bad MOBO. I'm out of RMA range, so I'm inclined to try to revive it on my own before I spring for a new, higher end, MOBO.

What would you do in this situation? Should I try playing with the jumper to "clear" the CMOS, or did removing the battery and replacing it accomplish the same thing?
m
0
l
a c 117 V Motherboard
March 17, 2011 11:45:58 PM

Test or replace the coin battery it could be dying.
They're like $3.
All your symptoms you've just described point towards a bad cmos battery.
m
0
l
March 17, 2011 11:51:06 PM

I tested it and it's good. Should I try playing with the jumper to "clear" the CMOS, or did removing the battery and replacing it accomplish the same thing?
m
0
l
a c 117 V Motherboard
March 18, 2011 10:04:17 AM

thewanderer14 said:
I tested it and it's good. Should I try playing with the jumper to "clear" the CMOS, or did removing the battery and replacing it accomplish the same thing?

Yes do exactly that it will reset your bios.
Either way will accomplish the same result.
When you're finished. load optimized defaults.
m
0
l
March 24, 2011 7:38:37 PM

Alright... The saga continues. Reset the BIOS with the jumpers. It worked for a few days, turning off and rebooting like a champ. Then, bang zoom back to the BOOTMGR corrupt error. Then, went to reset the BIOS on the jumpers again and would not POST. Tried removing the battery, would also not POST.

Called Biostar and got a great guy helping me out. He had me pull both sticks of RAM, and sure enough the MOBO screamed bloody murder until I powered it off with the kill switch in the back of the PSU. So, I guess that means the MOBO didn't blow up.

He then had me insert only one stick of RAM, and sure enough it booted right back up. Could bad RAM be causing this? I'm in observation mode to see how it runs with just this one stick.
m
0
l
!