Sign in with
Sign up | Sign in
Your question
Solved

AHCI Options Question (MSI G45M Digital)

Last response: in Storage
Share
August 9, 2012 2:50:32 PM

I just completed an install for a Samsung 830 on an MSI G45M Digital motherboard. When setting the AHCI settings, I found two options to toggle. One was for the Raid (IDE/AHCI) and the other was in the on-board ata options sections. I set both to AHCI just to be sure.

The install went without issues and everything is all set, except I feel that one of those AHCI options were unnecessary. When booting up, a screen shows for a couple seconds saying something along the lines of "No Drive Found" (sorry, I'm at work and that's the best I remember the text). I feel I may have set some type of RAID configuration on and it is added an extra step to my boot process.

Is there any harm in toggling the settings to see if I need both AHCI options flipped on? Will it affect the data on my drive? If anyone is familiar with my motherboard, perhaps you can tell me exactly which setting should be default.
a b V Motherboard
August 9, 2012 3:15:42 PM

I can tell you that it is for sure the RAID (IDE/AHCI) setting that is causing the no driver found issue....its looking for a RAID driver at bootup....just disable the raid in the BIOS and that will not come up again.
m
0
l

Best solution

a b V Motherboard
a c 523 G Storage
August 9, 2012 3:18:55 PM

If you have no drives connected to your IDE controller then set "Extra IDE Controller" to "Disabled" (page 3-13 of your motherboard manual). That should make the "No drives found" message disappear.
Share
Related resources
Can't find your answer ? Ask !
August 9, 2012 9:41:08 PM

Best answer selected by sonofjenova7.
m
0
l
August 9, 2012 9:43:26 PM

drums101 said:
I can tell you that it is for sure the RAID (IDE/AHCI) setting that is causing the no driver found issue....its looking for a RAID driver at bootup....just disable the raid in the BIOS and that will not come up again.


I looked all over but for both of my RAID settings, the only options were (IDE/AHCI) or (IDE/RAID/AHCI). There are no options to disable RAID. I turned off the extra IDE and E-Sata support though and it seemed to fix the issue.
m
0
l
August 9, 2012 9:43:36 PM

Dereck47 said:
If you have no drives connected to your IDE controller then set "Extra IDE Controller" to "Disabled" (page 3-13 of your motherboard manual). That should make the "No drives found" message disappear.


I went ahead and disabled both the Extra IDE as well as the e-sata. This managed to get rid of the prompt at start up. Thanks!
m
0
l
!