IIS problem playing video in XP Pro

Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

I have a web site that has links to a few .mpg video files.

When I just open the html file in IE and click the link, the video plays fine.

When the page is served by IIS, I get the following error:

"Windows media player cannot play this file. Connect to the internet or
insert the removable media on which the file is located, and then try to play
the file again."

The pages and videos are located on a USB hard drive on the IIS server
machine as E:

This setup has worked fine on several other computers running IIS and
Windows 2000. I did not have to set MIME settings on these computers.

I even tried adding the MIME extensions on the IIS server HTTP page as
..mpg video\mpeg
..mpeg video\mpeg

This is a brand new Dell M60 Workstation laptop.

Versions of software being used:

IE 6.0
XP Pro SP2
IIS V5.1
WMP 9.0

It seems the MIME settings should have worked, but those should have been
standard default settings anyway.

Any ideas?
1 answer Last reply
More about problem playing video
  1. Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

    You'll most likely get a more accurate answer if posted in one of the IIS
    groups, but my having to guess, I'm guessing either the IIS lockdown tool
    has been run or IIS security is setup to not allow IIS to serve any files
    outside of its designated file system, which is normally c:\inetpub - you
    may wish to check it out.

    --
    Star Fleet Admiral Q @ your service!
    "Google is your Friend!"
    www.google.com

    ***********************************************

    "ted_thompson61" <tedthompson61@discussions.microsoft.com> wrote in message
    news:F896CC14-BC86-43F1-9141-2E7637532FC0@microsoft.com...
    > I have a web site that has links to a few .mpg video files.
    >
    > When I just open the html file in IE and click the link, the video plays
    fine.
    >
    > When the page is served by IIS, I get the following error:
    >
    > "Windows media player cannot play this file. Connect to the internet or
    > insert the removable media on which the file is located, and then try to
    play
    > the file again."
    >
    > The pages and videos are located on a USB hard drive on the IIS server
    > machine as E:
    >
    > This setup has worked fine on several other computers running IIS and
    > Windows 2000. I did not have to set MIME settings on these computers.
    >
    > I even tried adding the MIME extensions on the IIS server HTTP page as
    > .mpg video\mpeg
    > .mpeg video\mpeg
    >
    > This is a brand new Dell M60 Workstation laptop.
    >
    > Versions of software being used:
    >
    > IE 6.0
    > XP Pro SP2
    > IIS V5.1
    > WMP 9.0
    >
    > It seems the MIME settings should have worked, but those should have been
    > standard default settings anyway.
    >
    > Any ideas?
    >
Ask a new question

Read More

Configuration Video IIS Windows XP